File won't unzip

Discussion in 'Mac Basics and Help' started by jdevenberg, Jul 6, 2011.

  1. jdevenberg macrumors newbie

    Joined:
    Jul 6, 2011
    #1
    I just got my Mac and am trying to move all my photos over from my old PC. The PC keeps frying any external storage I hook to it so I had to upload all 18+ GB of pictures to my Windows Live SkyDrive. Now when I download them it comes in a .zip file and my Mac can't open them. I have tried the built in unarchive tool, The Unarchiver, Stuffit, and zipeg and none of them can do it. Any advice on what I should do?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Can you enable file sharing on the Windows PC and Mac? That way you can easily transfer files and they shouldn't be zipped that way.
     
  3. hehe299792458 macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #3
    I'm more concerned why your PC fries external drives. Are you sure you files aren't corrupted?
     
  4. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
  5. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #5
    I would see if you can try getting your hands on a PC that is running Vista or higher. 18GB is well over the limit of the ZIP format (Max 4GB archive size and maximum 4GB file size) and I've had really odd interoperability issues when dealing with the Zip64 format.
     
  6. jdevenberg thread starter macrumors newbie

    Joined:
    Jul 6, 2011
    #6
    I will try file sharing. I know how to set it up on the windows PC, but not on the mac. I am sure the files aren't corrupt because they work fine if downloaded one by one. As stated in my original post, I already tried stuffit.

    Also the laptop in question is running Vista and I have access to a windows 7 box
     

Share This Page