Files Being Placed Behind Others In Icon View

Discussion in 'macOS' started by gary001, Nov 9, 2009.

  1. gary001 macrumors member

    Feb 10, 2008
    Most of the time when I download a file or unzip a file, the resulting file gets placed behind an existing one. Like instead of the file being placed in the next open spot, it ends up where another file is, making it seemingly disappear. I then have to look through the entire folder to find it and put it in an empty spot. This occurs when in icon view only, and is VERY annoying! What is happening here and how do I fix it? I'm using 10.6.2 on a June '09 MBP. This has been happening for a while now but I don't remember if this was occurring pre Snow Leopard too.

    Here's an example of what I mean:
    [​IMG] [​IMG]
  2. gary001 thread starter macrumors member

    Feb 10, 2008
  3. pcguru83 macrumors 6502a


    Sep 13, 2006
    Charlotte, NC
    Can't help unfortunately, but I'm fairly certain I've had this happen as far back as Tiger. I know for usre it happened to me severeal times under Leopard. I've only noticed it happen on the Desktop, and it primarily (maybe even solely) happens after I unzip the contents of a zipped file. It is very annoying, as even when you see it, it can be hard to "grab" the correct file.

    But I don't believe this is new to Snow Leopard.
  4. Graig macrumors 6502


    Aug 23, 2009
    Vancouver, BC
    Just right-click in an open spot and arrange by name. They will all line up.
  5. stevearm macrumors 6502a

    Nov 15, 2007
    Right click an empty space in the folder you're viewing. Then hold down the funny little button a couple of spaces to the left of the space bar (I'm new to mac).

    Holding that button down should change "Arrange by" to "Keep Arranged by". A very useful feature of Finder. Then either click 'name', 'date' or 'type'. That'll stop that from happening ever again (but only in that particular folder)
  6. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    But that shouldn't happen to begin with. It's not proper or normal behavior. I suspect corrupt Finder or Desktop preferences.

Share This Page