Files deleted when copied over network

Nermal

Moderator
Original poster
Staff member
Dec 7, 2002
18,737
1,210
New Zealand
My Mac's hooked up to a Windows machine. I can mount the Windows HD on my desktop, and copy files onto it. However, sometimes when I copy files from Mac to Windows, I see the file copy, it takes a while if it's a big file, then it just appears to delete itself off the Windows machine. Try it again and it usually works, although sometimes I need to try 5 or 6 times before the file will stay there.

This doesn't happen all the time, sometimes a file will copy perfectly, other times it takes several attempts to get the file to stay there. It seems to happen most with .exe files but I have seen it happen with other file types too. It also seems to happen most in the root directory - sometimes I end up making a folder and copying into that, which usually works.

I never have this problem when going from Windows to Mac, just Mac to Windows. My Mac's running 10.2.6 and I don't think I've installed any "special" networking software. The PC's got Windows 2000. I've got a suspicion that my anti-virus may be the culprit, it's Trend PC-cillin 2002.

Any ideas?
 

scan300

macrumors 6502
Mar 25, 2003
256
0
Melbourne, Australia
I think your suspicion is the best candidate for investigation.

Copying executables may cause your anti-virus software to see red. They could also have viruses, which may not be picked up on your Mac.

Also check your permissions, as a root directory is not a common place to copy things in a modern set-up unless you're the admin of the machine.
 

Nermal

Moderator
Original poster
Staff member
Dec 7, 2002
18,737
1,210
New Zealand
I'll need to do some testing with the AV turned off, it's hard to test because it's intermittent. I tried copying a pdf across today and that disappeared too. Second attempt worked.