Files Permissions on iPod as Mass Storage Device Corrupted

Discussion in 'iPod' started by ColinScatt, May 1, 2009.

  1. ColinScatt macrumors newbie

    Apr 1, 2009
    Hey all.

    So I have an iPod Classic with a cracked screen, and used it for a long time after I got a new Nano to store my iTunes library to take my (75GB) iTunes library w/ me anywhere I went, rather than store it on my comp. I didn't just use it in iTunes mode, I stored the folders and files on there using it as USB Mass Storage.

    This worked fine for the time that I had my iBook G4. Then, the iBook's logic board failed, and now I have a MacBook with a 320GB hd, aka plenty of room to store my library. My issue is that now when I plug in the iPod, it is detected as it used to be, but when I try to copy stuff off of it, some of the files will copy fine, but a lot of the files start copying, then stop and give me an error saying I don't have permission to edit the file or whatever, and basically freezes Finder.

    Does anyone have any good solutions to this???

    I tried to use Disk Utility to Repair Permissions on the iPod, but you can only click Verify Disk and Repair Disk, both the "Permissions" options are greyed out and unclickable.

    I need my Music and Movies back! Help!!!

Share This Page