Files saved Hidden by default

Discussion in 'macOS' started by gr4z, Jun 6, 2012.

  1. gr4z macrumors regular

    Joined:
    Aug 7, 2010
    Location:
    England
    #1
    Hi

    I have this issue which is driving me mad. When I save files to certain folders they are hidden by default. They can be anything, for example PDF from the net to a custom folder I have created in Documents.

    Why is this and how can I revert so that all files I can use and download are saved normally?

    Thanks
     
  2. smirk macrumors 6502a

    smirk

    Joined:
    Jul 18, 2002
    Location:
    Orange County, CA
    #2
    Hi, can you explain what you mean by "they are hidden by default"?
     
  3. gr4z thread starter macrumors regular

    Joined:
    Aug 7, 2010
    Location:
    England
    #3
    Whenever I save a file to that folder, it is saved as a hidden file. I have to then use chmod to remove the hidden flag.
     
  4. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #4
    chmod sets file permissions, not any sort of hidden status. So, I have no idea what problem you actually have.
     
  5. gr4z thread starter macrumors regular

    Joined:
    Aug 7, 2010
    Location:
    England
    #5
    Sorry me being an idiot - I have tried so many damn things. I have to use chflags -nohidden to make the files not hidden.

    If I save the file to another folder and copy them into this one its fine. Its only if I save direct to this folder.
     
  6. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #6
    That's a weird one.

    Any chance you can move the goofy folder to a new name, and create a new folder by the same name, and see if the problem goes away?
     

Share This Page