FileShare between Mac and Windows 7

Discussion in 'Mac Basics and Help' started by darkpixie08, Jun 14, 2011.

  1. darkpixie08 macrumors member

    Joined:
    Sep 6, 2006
    #1
    I have a mac mini running 10.3.9 and a windows 7 computer that I would like to fileshare between. They are both on the same wireless network, but can not seem to connect between the two of them (I can't even see the mac on the windows computer). I have gone to system preferences on the Mac Mini and turned on file sharing. Is there some other step that I'm missing? This really should not be that difficult, right? If someone could walk me through this like I'm five years old, I'd really appreciate it.
     
  2. Peteman100 macrumors 6502

    Joined:
    Apr 28, 2011
    Location:
    Berkeley, CA
  3. jamietshaw macrumors member

    Joined:
    Sep 25, 2009
    Location:
    UK
    #3
    Select File Sharing again, and click on the Options button that appears to the right. You need to turn on SMB sharing for it to work with Windows.
    (There are various protocols for connecting to other computers. Macs can use AFP and SMB; Windows only SMB)
     
  4. darkpixie08 thread starter macrumors member

    Joined:
    Sep 6, 2006
    #4
    Unfortunately that is not doing the trick, as I already had that selected. Any other suggestions out there (apart from throwing my husbands PC out the window!!)?
     
  5. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #5
    Is there no way to upgrade the 10.3.9 system to 10.4 or 10.5?
     
  6. darkpixie08 thread starter macrumors member

    Joined:
    Sep 6, 2006
    #6
    I suppose I could, but spending $100 on a new operating system just to get my computer to network to another seems rather silly. I would sincerely hope Panther would be able to network to a PC.
     
  7. wpotere Guest

    Joined:
    Oct 7, 2010
    #7
    OK, if you are expecting it to automatically show up, it won't.

    Which direction are you trying to share (mac folder or Windows folder)?
     
  8. darkpixie08 thread starter macrumors member

    Joined:
    Sep 6, 2006
    #8
    I would like to access files stored on the mini from the windows computer please.
     
  9. thejadedmonkey macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #9
    Just get the PC's IP address and command+K it, type in the IP address, and you're good to go. Conversely, get the Mini's IP address, Windows+R it, and type in the IP. There's no good way to share files between OS X and Windows, even between Windows 7 and Snow Leopard. Upgrading the OS won't do you any good, just slow down the mini.

    P.S. I still use the same mini as a jukebox in my basement, it's wonderful!
     
  10. darkpixie08 thread starter macrumors member

    Joined:
    Sep 6, 2006
    #10
    Thank you, I'll go ahead and give that a try once my husband finishes up his Starcraft-ing for the evening!

    I'm glad to here the mini is working for you. We use ours primarily for a media server, and stream to a couple AppletTVs in the house, and I absolutely love it.
     
  11. darkpixie08, Jun 16, 2011
    Last edited: Jun 16, 2011

    darkpixie08 thread starter macrumors member

    Joined:
    Sep 6, 2006
    #11
    Ok, on the PC I did the shortcut windows+R, and it brought me to the run command, I then typed in the mac's IP address and nothing. Same problem with the Mac side. Any other possible solutions?
     
  12. darkpixie08 thread starter macrumors member

    Joined:
    Sep 6, 2006
    #12
    Do I need to add this mac to the homegroup on the windows PC? If so, how do I do that?
     
  13. wpotere Guest

    Joined:
    Oct 7, 2010
    #13
  14. darkpixie08 thread starter macrumors member

    Joined:
    Sep 6, 2006
    #14
    Sorry guys mapping the network drive didn't do the trick either. I pressed map network drive, selected a drive letter, typed in \\ip address\ and I get an error message that says "Windows can not access \\ip address" I also tried using the computer name instead of the IP address. I also tried clicking on the option to connect using different credentials and punched in my mac account name and password on there. Nothing.
     
  15. darkpixie08 thread starter macrumors member

    Joined:
    Sep 6, 2006
    #15
    File sharing with a PC... again

    Ok, I've upgraded to 10.5.8, and it still isn't working.

    They are on the same wireless network

    From the Mac side:
    I've made sure all the folders are shared both read and write
    SMB is enabled
    Disabled the Firewall

    From the PC side I've
    Tried mapping the network;
    Tried running a command and then inputting the ip address
    Enabled network discovery
    Disabled the firewall

    Where do I go from here. This is ridiculous, and calls to both microsoft and apple support blame the other side/won't help because it's not part of their customer support. Bah.
     
  16. wpotere Guest

    Joined:
    Oct 7, 2010
    #16
    Wait, you typed "\\the_ip\" and that was it? That won't work either....

    You have to type "\\the_ip\the name of the folder" without the quotes. So, it would be the IP address of the mac and then the folder name that you are sharing via SMB.

    Here is an example.

    http://lifehacker.com/247541/how-to-access-a-macs-files-on-your-pc
     
  17. darkpixie08, Jun 16, 2011
    Last edited: Jun 16, 2011

    darkpixie08 thread starter macrumors member

    Joined:
    Sep 6, 2006
    #17
    Thank you for the example. I was doing it wrong, but now that I'm doing it correctly, I am having no more success. I don't get an error message, but windows explorer never pops up.

    ETA: I can now see the pc and access it from my macs, but I need to be able to do things from the PC side.
     
  18. wpotere Guest

    Joined:
    Oct 7, 2010
    #18
    Did you see the comment at the very bottom of that page about the workgroup?
    Check that and then also check your firewalls on each machine. You might want to disable them temporarily (if you are behind a router) to see if that is what is causing the problem.
     

Share This Page