Filesharing using own account in stead of guest's...

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Esperzoa, Aug 23, 2009.

  1. Esperzoa macrumors newbie

    Joined:
    Aug 23, 2009
    #1
    Hi all,

    After hours of getting my network working using XP to connect to my Macbook pro i stumbled across a small problem.

    I now am able to "see" into my Mac's shared folder, but only using the quest account. When i try to login using my own account i get the message that i do not have enough rights for the networksource, even though i set the rights to "Read and Write".

    What i'm trying to achieve here is to use my own account for private files, while letting other people use the guest account with limited rights, so they can't delete/add/modify the ones i own.

    The settings are as shown in the pictures:

    [​IMG]

    [​IMG]

    [​IMG]

    (For now i have set the guest account to full rights also. This is only until this is resolved.)

    Anyone know what i'm doing wrong? Any help would be appreciated.
     
  2. CarpetMonster macrumors newbie

    Joined:
    Jun 13, 2007
    #2
    XP will try to connect to a share as the current logged in users credentials first, then as a guest.

    In the first pic, set everyone to no access, so that only the account you want to access the share has permissions to do so.

    In the second pic you need to tick the On box for the SMB account you're going to use (the same that has permissions in the first pic) and enter the samba password.

    Then you can map a drive, either in explorer Tools > Map network drive (remembering to click the option Connect using a different user name) or at the command prompt, so for drive Z
    net use z: \\server\share /user:username

    and it will prompt for the password. You can substitute z: for * to get the next available drive and server for the server's IP address. For a persistent connection add at the end /persistent:yes
     
  3. Esperzoa thread starter macrumors newbie

    Joined:
    Aug 23, 2009
    #3
    Hi there CarpetMonster, thanks for helping out.

    I now have setup everything you suggested. It works no problem but now there are two things i'm concerned about:

    1) When i click on my Shared Folder i don't get the login screen anymore. It just logs in without asking for a username and password.

    2) I now get a new networklocation which navigates to my whole userprofile. Also without asking for a username and password.

    I find this a little distressing since now i assume that everyone in the network is now able to get to my important files without permission.

    CarpetMonster, is there any way i can get rid of the shared folder which points to my profile by either deleting or even securing it with a password?

    Thanks in advance.
     

Share This Page