filevault 2 problem

Discussion in 'MacBook Pro' started by edwardjulio, May 12, 2015.

  1. edwardjulio macrumors newbie

    Joined:
    Dec 7, 2014
    #1
    I have 13 inch macbook pro retina mid-2014, i have been turning on my file vault since the day 1, i have never experienced any problem. This morning, when i turn on my mac, just right after I input my password, my mac suddenly restarted by itself, then asking me a password again, with different wallpaper that i use (the yosemite default wallpaper). Since then, when I turn on my laptop, it has different behavior.

    Before: When i turn on my mac, mac will ask to choose "guest account" or my account, once i choose my account, i input my password, then it will show the loading screen.

    now: once i turn on my mac, there will be an apple logo with loading bar, then it only shows 1 account which is my account (there is no guest account option anymore), once I input my password for my account, it will enter to my account immediately, it seems like the file vault does not work ( decrypting the hard drive will take a longer time than that) ,

    when i check my file vault status on system preferences, it shows that my file vault is on.

    is this a bug with file vault? any suggestion?

    thanks
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    It doesn't decrypt the file in that way, once you give it a valid key it encrypts and decrypts the data as it is read and written.

    I think you have FV2 enabled, no idea why the behaviour has changed though...
     
  3. Honza1 macrumors regular

    Joined:
    Nov 30, 2013
    Location:
    US
    #3
    Boot in recovery (cmd-r during power on) and check in DiskTools. It will tell you. And if you need to put in your password then to mount it, it is still encrypted. If not, it is confusing...
     

Share This Page