FileVault and Yoesemite Shutdown Problem

Discussion in 'OS X Yosemite (10.10)' started by jyyz, Oct 17, 2014.

  1. jyyz macrumors regular

    Joined:
    Oct 17, 2014
    #1
    Upgraded to 10.10 started having problems with system shutdown. Seemingly at random the system would cut to a black screen with the mouse pointer visible and keyboard backlight would remain on. It would take anywhere from 10 to 20 minutes to completely shutdown in this state.

    Tried reinstalling OS X from the recovery disk - the problem recurred.

    Tried wiping the start up volume, reinstalling OS X from the recovery disk, and used migration assistant from a back up - problem recurred.

    Erased the start up volume again, reinstalled OS X, used migration but disabled FileVault this time - everything seems to be working well.

    Wondering if anyone else is experiencing this problem? I would like the added security of FileVault, but can't have that long of a shutdown.

    Another point, with FileVault enabled the login screen refuses to just start with the name and password field - no matter what system preferences I made, it would default to the user picture and name being displayed.

    I also changed the Apps Downloaded from setting from Mac App Store and Identified Developers to Anywhere, but that didn't seem to resolve the shutdown issue when FileVault was enabled. Also verified the disk had no issues, ran a permissions repair, reset PRAM, reset SMC.

    MacBook Pro (Retina, 15-inch, Late 2013), OS X Yosemite
     
  2. dugbug macrumors 65816

    dugbug

    Joined:
    Aug 23, 2008
    Location:
    Somewhere in Florida
    #2
    I have the same problem but do not use file vault. I did a repair on the primary partition and a restart. It took some time but it successfully restarted. I don't know if the problem has cleaned itself up by doing that, but I have not had the black screen with mouse during shutdown since.


    edit: once it seemed to be caused by my bluetooth keyboard going away. That seems to be a sensitive pairing.
     
  3. Offpunk macrumors newbie

    Joined:
    Oct 19, 2014
    #3
    I 'm having the same problem since I 've upgraded my 2012 retina macbook pro to 10.10. The screen freezes all the time, applications can't be loaded or closed and filevault is stuck on optimizing... I've tried restoring from my time capsule but it freezes on searching for disks... I 'm so frustrated right now. It seems like there is no way out. How can you fix a hard disk when you cannot access it?
     

Share This Page