FileVault Corruption - Unable to access or erase SSD encrypted with FileVault

Discussion in 'OS X Mavericks (10.9)' started by GTLegend, Oct 26, 2014.

  1. GTLegend macrumors newbie

    Joined:
    Oct 26, 2014
    #1
    Hi guys, here's a problem I hope you can help me with.

    I have an OCZ Vector 4 SSD in my 2010 17 inch Macbook Pro running as the boot disk. The disk is running FileVault. The machine suddenly would not wake up from sleep mode. I rebooted, got as far as my user login, entered my password and it just sat on the apple logo, with progress indicator spinning.

    I put the machine in target mode and tried to recover my data from another mac. The FileVault dialogue box asked for my password. I entered it, it shook its head. I entered my security key which I had saved, same story. These are 100% the correct password and key for FileVault.

    Basically, I suspect that my FileVault encryption has corrupted and no longer recognises my password / security key.


    DISK UTILITY

    I resigned myself to losing the data (had a fairly recent time machine backup) so decided to erase the disk and reinstall / restore from Time Machine.

    The disk will not erase from Disk Utility, it fails 2/3rds of the way through, with this error message:

    "Disk Encryption Failed with the error: Unable to delete the CoreStorage logical volume group."

    I tried to verify the disk from Disk Utility (from the other machine), the disk appears to be okay. Try to repair permissions, it fails 2/3rds of the way through.


    TERMINAL

    I tried to format from the terminal as per the following:

    diskutil cs list:

    CoreStorage logical volume groups (1 found)
    |
    +-- Logical Volume Group 472A0E05-B077-4D9A-A65B-401022C2EEFD
    =========================================================
    Name: Monster 256
    Status: Online
    Size: 255200755712 B (255.2 GB)
    Free Space: 16777216 B (16.8 MB)
    |
    +-< Physical Volume 388E8968-CBC3-46FF-9C9D-398BC560D9B4
    | ----------------------------------------------------
    | Index: 0
    | Disk: disk2s2
    | Status: Online
    | Size: 255200755712 B (255.2 GB)
    |
    +-> Logical Volume Family 67D1A14B-7D50-4E68-A956-EE55C77A7DC3
    ----------------------------------------------------------
    Encryption Status: Locked
    Encryption Type: AES-XTS
    Conversion Status: Complete
    Conversion Direction: -none-
    Has Encrypted Extents: Yes
    Fully Secure: Yes
    Passphrase Required: Yes
    |
    +-> Logical Volume B8F8E3A2-D505-49D2-B7DF-7FDE1CE29145
    ---------------------------------------------------
    Disk: -none-
    Status: Locked
    Size (Total): 254865207296 B (254.9 GB)
    Conversion Progress: -none-


    Then: diskutil eraseDisk HFS+ "Monster 256" disk2

    It says, Umounting disk, then sits on the backslash progress indicator, indefinitely.

    I tried:

    diskutil cs delete 472A0E05-B077-4D9A-A65B-401022C2EEFD

    It progresses to 67% then returns this error:

    diskutil cs delete 472A0E05-B077-4D9A-A65B-401022C2EEFD
    The Core Storage Logical Volume Group UUID is 472A0E05-B077-4D9A-A65B-401022C2EEFD
    Started CoreStorage operation
    Ejecting Logical Volumes
    Destroying Logical Volume Group
    Erasing disk2s2
    Error: -69876: Couldn't read partition map
    Roadwarriors-MacBook-Pro-2:~ roadwarriormbp$


    I've also tried unlocking with the password and security key from the terminal:

    diskutil corestorage unlockVolume B8F8E3A2-D505-49D2-B7DF-7FDE1CE29145 -passphrase 2OZM-4UD7-FYXK-FYD9-M9Z7-EQKY
    Started CoreStorage operation
    Logical Volume successfully unlocked
    Error: -69774: Couldn't bring the new Core Storage Logical Volume online
    Roadwarriors-MacBook-Pro-2:~ roadwarriormbp$


    I've tried diskutil zeroDisk disk2

    It returns this:

    diskutil zeroDisk disk2
    Started erase on disk2
    Error: -69879: Couldn't open disk
    Underlying error: 2: POSIX reports: No such file or directory
    Roadwarriors-MacBook-Pro-2:~ roadwarriormbp$


    I've tried repairing the volume from the terminal. It returns a successful result, but changes nothing (passwords don't work / still can't erase etc)


    WINDOWS

    I've also tried to format it from a Windows Machine. Windows recognised it, installed drivers for it, but it does not appear in the explorer. Installed Paragon, to read HFS on Windows, no change.

    Listed all drives from the command prompt, the drive does not appear, but a small FAT32 EPI Volume does appear.

    Ran an app called EaseUS Partition Master. The software sees the drive, but hangs when trying to format or partition etc.


    OCZ SOFTWARE

    I've also tried running OCZ's Toolbox software for the drive, both on mac and pc, both executable and boot versions, none recognise the drive. (I've used this toolbox before to upgrade the drive's firmware.)



    So, I'm out of ideas. I'm convinced that the drive is physically okay, but that FileVault encryption has corrupted. Any other ideas at all? I'd love to hear them.

    Let me know, thanks in advance...
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I'm not clear... have you tried the drive in an external enclosure? A bad drive cable can cause symptoms like this and testing in an enclosure would eliminate that as the cause. Otherwise, it sounds like a failed drive to me.
     
  3. GTLegend thread starter macrumors newbie

    Joined:
    Oct 26, 2014
    #3
    Thanks for the reply. Yes, I've tried it with various enclosures, no difference. Do you think it could be a failed drive even though it verifies ok?
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Yes it is possible. DU is not the most thorough drive test tool.
     

Share This Page