Filevault stuck while encrypting the HD

whatmac

macrumors newbie
Original poster
Dec 21, 2014
6
0
Hi!

my mac is stuck for the last week while I m trying to encrypt the hard disk with the filevault. Since a few days it says "encrypting" but it is not progressing, it also says calculating remaing time but still no action. The full systems is currently ultra slow and sometimes it blocks.

At this very moment I can t stop the encrypting, any advice ?

My mac is a macbook pro from 2012 running on High Sierra


Thanks!
 

Brian33

macrumors 6502a
Apr 30, 2008
808
64
USA (Virginia)
You can use the diskutil command in Terminal.app to check the progress of drive encryption. I think the command I used to show the progress was diskutil list but maybe it was diskutil apfs list

Awhile ago I tried to set up a new encrypted backup with Time Machine. Oddly, it did the first backup and then tried to encrypt the disk. It was taking days and days with very little progress. I discovered that while I was using the Mac it would make decent progress, but that when the Mac went to sleep, the encryption progress would virtually stop. I eventually gave up on it. I only mention this because maybe you have the same odd encryption behavior and your machine is usually asleep... something to check, anyway. If you have the same behavior you could probably come up with a way to keep your Mac awake (perhaps the caffeinate command).