Fill the form without capitalization

Discussion in 'iOS 10' started by hiro_hamada, Jan 27, 2017.

  1. hiro_hamada macrumors newbie

    Joined:
    Jan 25, 2017
    #1
    I want to keep Auto capitalization enabled, but there's a problem with filling certain forms (emails, usernames...) where I have to type second letter and then erase first to keep the lowercase (eg: Uusername, and then delete "U"). My logic says it should type in lowercase by holding shift, but it doesn't work that way on iOS. Is there a workaround?
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    If it's set to type in upper case then you will see the shift key active/enabled before that, you can simply deselect it (by tapping on it) and it will use lowercase.
     
  3. hiro_hamada thread starter macrumors newbie

    Joined:
    Jan 25, 2017
    #3
    Um, I forgot to mention that I use Smart Keyboard and it won't work by holding Shift.
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    As in the iPad keyboard built into an iPad cover? Shift doesn't work there to change the case?
     
  5. hiro_hamada thread starter macrumors newbie

    Joined:
    Jan 25, 2017
    #5
    Not if the form is set to start with capital letter. Holding shift won't change anything.
     
  6. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    But, even with first capital, doesn't press and release shift toggle the case of the next character typed?
    (I may be ignorant about this - I have never used a Smart Keyboard)
     
  7. hiro_hamada thread starter macrumors newbie

    Joined:
    Jan 25, 2017
    #7
    It does for the next character, but then I have to type first character uppercase and the next lowecase and then back and delete first character.
     
  8. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    Seems like auto-caps is controlling you, and not the other way round.
    So, turning off auto-caps is your work-around, eh?
     
  9. hiro_hamada thread starter macrumors newbie

    Joined:
    Jan 25, 2017
    #9
    Yea, that's the only way, but then I don't have auto-capitalization where I want to have it :)
     
  10. Suckfest 9001 macrumors 65816

    Suckfest 9001

    Joined:
    May 31, 2015
    Location:
    Canada
    #10
    I also ran into this issue. Massive oversight by Apple that you can't even force it to use small characters. I turned off auto capitalization for external keyboards.
     
  11. GreyOS, Jan 28, 2017
    Last edited: Jan 28, 2017

    GreyOS macrumors 68040

    GreyOS

    Joined:
    Apr 12, 2012
    #11
    I think this is actually a problem with the website, as the website can either say not to uppercase in a certain field, or it can semantically describe what the field is for so that Safari behaves in an appropriate way (e.g.for email or username fields)

    Edit: sorry I missed the point, this is about the fact the obvious workaround for bad sites is not actually working on external keyboards
     
  12. Lisat78 macrumors member

    Joined:
    Jun 5, 2015
    #12
    I've had issues with this too. Getting auto fill to fill in the details usually gets around it as ios seems to throw up the correct info according to the field type, but it drives me nuts on the rare occasion when I have to type manually. I'm using both the on-screen and an external Bluetooth keyboard; as said above, the only other workaround seems to be to type the first letter twice and delete the unwanted upper case.
     
  13. Feenician macrumors 601

    Feenician

    Joined:
    Jun 13, 2016
    #13
    Yes this one bugs me too with the smart keyboard and falls into the "did they even test this?" category. Maybe the solution is for them to put a small caps overlay graphic in the text field, similar to the passwords key one, when the keyboard is attached.
     

Share This Page