Final Cut 6 and Snow Leopard?

Discussion in 'Mac Apps and Mac App Store' started by buxtone17, Sep 28, 2009.

  1. buxtone17 macrumors regular

    Joined:
    Jan 16, 2009
    #1
    I'm trying to install Final Cut Studio (6.0.1) on a C2D MBP running Snow Leopard (10.6).

    This is my third attempt, after restarting and then shutting down and resetting PRAM, and the install keeps getting hung up on "Running package scripts..."

    Installer is responsive, it's just getting stuck for some reason.

    Anyone else having this issue?
     
  2. agentkow macrumors 6502

    agentkow

    Joined:
    Oct 1, 2003
    Location:
    Vancouver, Canada
    #2
    Yes, I am, but the outlook is not good. Everything I've read points to the need to do a fresh install of both the system and Final Cut. I upgraded to Snow Leopard over my existing Leopard install, and everything has been working fine until this. I wouldn't be re-installing Final Cut if it hadn't stopped working in Snow Leopard in the first place...
     
  3. snackbarfilms macrumors newbie

    Joined:
    Oct 16, 2009
    #3
    Did you ever sort this out? I'm having the same problem now. Thanks, Brian
     
  4. agentkow macrumors 6502

    agentkow

    Joined:
    Oct 1, 2003
    Location:
    Vancouver, Canada
    #4
    I was able to reinstall using the following method:

    1. I removed the Final Cut suite using the fantastic find, FCS Remover
    2. I opened the installer program from the disc and only chose "Final Cut Pro" to install from the custom install list (not sure if this helped the process or not)
    3. When it got to the part where "Running package scripts..." stalls out, I waited a bit, and then force quit the installer.
    4. I restarted my Mac, and ran software update, which now has updates for the "Pro Apps". Ran those too.
    5. Started up Final Cut and have been using it ever since.

    Since then I've even imported, edited and exported a movie no problem. Also went back and installed "Motion" right from the individual Motion disc, and have been using that too.
     
  5. jaxmcg macrumors newbie

    jaxmcg

    Joined:
    Nov 24, 2009
    #5
    wow, that is a fantastic find!

    I ran it to try and solve the same problem but no avail :(

    My problem still stands.
    I need final cut 6.0.1 to run on new 10.6.2 imac.
    every time i go for install this happens..(screenshot below).. it says SKIP next to final cut pro..why does it do this? and more importantly how on earth can i fix it?!?!?
     

    Attached Files:

  6. Mrears macrumors newbie

    Joined:
    Dec 8, 2009
    #6
    Final cut studio 2 and snow leopard

    Greetings jax. Did you ever solve your final cut studio installation Issue? I have the same problem. Final cut studio and mac with 10.6 snow. When I try to install the final cut box is greyed out so not available to install. Any ideas would be greatly appreciated.

    Many thanks in advance.

    Mrears
     
  7. amarmitra macrumors newbie

    Joined:
    Mar 26, 2009
    #7
    Helpp!!

    I have the same exact problem. My Final Cut Pro during installations shows skip like in the screen shot.
    Please help. I am falling behind in the deadline for my college project. This worked fine when I had 10.5. I am thinking it is an issue with the OS. I upgraded to 10.6 recently.
     
  8. reuschj macrumors newbie

    Joined:
    May 6, 2010
    Location:
    Austin, TX
    #8
    Force Quit "translate" process

    I was having this problem and I think I found the solution. I was trying to install FCS 2 on my new computer (with Snow Leopard) and the installation would freeze at "Running Package Scripts." I tried many times, all with the same result.

    Finally, I went to the Activity Monitor to force quit the installer. I pulled up the CPU usage monitor and noticed that one fo the threads was at a steady 100%. I quit the installer, but it was still at 100%. I checked the process list and noticed that there was a PowerPC process titled "translate" still running with 100% CPU usage.

    So, I tried the install again. This time, instead of quitting the installer, I fore quit the "translate" process. Immediately, the installer kicked back into action and finished.

    Hope this helps.
     
  9. agentkow macrumors 6502

    agentkow

    Joined:
    Oct 1, 2003
    Location:
    Vancouver, Canada
    #9
    Oh that's awesome, thanks so much.
     
  10. chewbee macrumors member

    Joined:
    Aug 23, 2007
    #10
    This worked for me too. Thanks!!
     
  11. kendodesigns macrumors newbie

    Joined:
    Jun 8, 2011
    #11
    Final Cut 5 and Snow Leopard - kill the 'Translate' process

    Thanks Agentcow, I had the same problem with an install of FCP 5 on SL. Killing the 'Translate' process worked!
     

Share This Page