Final Cut 6 Install on SL 10.6.2

jaxmcg

macrumors newbie
Original poster
Nov 24, 2009
11
0
Just wondering if anyone else has had a simlar issue:

Im trying to install an older version of Final Cut to my brand new 10.6.2 iMac. I've tried several different versions, 5,6 and 7. The only one that has worked is 7. I need 6 for compatibility reasons between home and school.

Is there something im doing wrong in my install? I get to the screen where it asks to check exactly you want installed and for some reason everything else will check but the FCP box it is shaded and it says "skip" theres no option to change it. I dont get it :confused:

its driving me nuts!
 

FSMBP

macrumors 68020
Jan 22, 2009
2,496
1,356
I've installed FCS 2 on Snow Leopard 10.6.2

I would call up Apple support because there's no reason it should say that.
 

SimonMW

macrumors 6502
Jan 15, 2008
261
1
Final Cut Studio 2 works fine on my SL installation. Though I had to downgrade back to 10.6.1 because the MXO output breaks under 10.6.2.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.