Final Cut Express 4.0 Requirements

Discussion in 'Mac Apps and Mac App Store' started by Wicked1, Dec 21, 2010.

  1. Wicked1 macrumors 68040

    Wicked1

    Joined:
    Apr 13, 2009
    Location:
    New Jersey
    #1
    Ok so I am looking at getting FCE 4.0 but will it work well on either

    2009 Mini 2.0 Ghz, 4GB with 320GB HDD 16 MB Cache and 7200RPM

    2009 uMB 2.4 with 4GB/500GB Hybrid

    I am thinking I might need a machine with a deicated GPU
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    http://www.apple.com/finalcutexpress/specs.html

    It should be fine
     

Share This Page