Final Cut Pro 10.0.4 won't install on 15" i7 early 2011 Macbook Pro

Discussion in 'MacBook Pro' started by Apple2000, Apr 28, 2012.

  1. Apple2000 macrumors member

    Joined:
    Jul 19, 2011
    #1
    Currently running 2.3ghz quad core macbook pro with 6750m graphics card.

    When I download the Final Cut Pro X trial off of apple's website, and then open the .dmg file, it says "the following disk images could not be opened."

    Then it says for the reason "not recognized."

    How Do i install the Final Cut Pro X 10.0.4 trial?

    Thanks
     
  2. Simplicated macrumors 65816

    Simplicated

    Joined:
    Sep 20, 2008
    Location:
    Waterloo, Ontario, Canada
    #2
    Your system meets the requirements of FCPX. The disk image file is corrupt, likely due to an issue when downloading the file. Try downloading again.
     
  3. Apple2000 thread starter macrumors member

    Joined:
    Jul 19, 2011
    #3
    I have already attempted downloading it several times. I have the same issue each time. I also tried it on an older 2008 iMac, same exact error.

    The mac is at the latest software.
     
  4. Badrottie Suspended

    Badrottie

    Joined:
    May 8, 2011
    Location:
    Los Angeles
  5. jnolas2 macrumors member

    Joined:
    Jul 1, 2007
    Location:
    Chicago, IL
    #5
    When I tried downloading the trial of FCPX right now, the disk image file that downloaded was only about 15bytes. I tried downloading it a few times and it was still that same size. So the .dmg on Apple's servers is not any good. It doesn't matter what Mac you download that on, it will never open. So Apple has to fix the file on their end before you can download a proper trial version of FCPX.
     
  6. Boisv macrumors regular

    Joined:
    Feb 2, 2012
    #6
    I'm having the exact same problem right now trying to install the trial onto someone's MacBook Pro. I came here looking for the answer and I think jnolas2 is right. Apple goofed.
     

Share This Page