Final Cut Pro: General Error: Out of memory

Discussion in 'Mac Apps and Mac App Store' started by drwhit12, Dec 30, 2009.

  1. drwhit12 macrumors newbie

    Joined:
    Dec 30, 2009
    #1
    I am running Final Cut Pro 7 on a MacBook with a 2.4 Ghz Intel Core 2 Duo. I have used FCP to edit before using video from a camera that used mini DV tapes and that worked fine. I recently got the Flip Ultra HD, which records straight to MP4 with the following format: 1280x720, 30 FPS, H.264 video compression. I imported the files on my computer and then imported them into FCP. When I try to play them in the viewer I get a window that says: General Error. Then another window that says: out of memory. I have tried restarting both the computer and the program. What is the problem?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Has the video been converted to ProRes or AIC?

    FCP does not like H264 encoded videos, as such compressed footage is not ideal for editing, as not all frames are present, only approximations between two keyframes.

    Have you taken a look at the manual of FCP and your camera to see if they offer any information that might help you to properly import your footage?
    Because as far as I remember, it does (not specifically though with your camera model, as that is not what FCP is aimed at or was or is or ...).

    Also have a look at MRoogle to find similar threads or threads concerning your camera model and FCP.


    Ahhh, I forgot something else.
    http://www.google.com/search?client...general+error+out+of+memory&ie=UTF-8&oe=UTF-8
     

Share This Page