Final Cut Pro X dissolve duration

Ja Di ksw

macrumors 65816
Original poster
Apr 9, 2003
I just started using FCP X, and would like a shorter dissolve than given when I hit "add dissolve." Is there any way to change how fast it happens? And can I make this a default so I don't have to go into each transition and change it?

Thanks a ton :)


macrumors demi-god
Jun 10, 2006
In the project timeline, drag either edge of the gray transition box to shorten or lengthen it. Under "Final Cut Pro" (at the top) -> Preferences -> Editing, you can change the default transition length to something other than 3 seconds.


macrumors 6502
Jan 26, 2005
Somewhere in the US
Couldn't you also when the dissolve is applied in the timeline, right click and look for duration and change it from there? I know this is how I did it on FCP6 and 7.


macrumors 6502a
Jun 6, 2011
That is CTRL + D now.
Easiest to change the duration is to simply click on the edit point and drag it to taste.


The preset duration can be changed in the Preferences.

Ja Di ksw

macrumors 65816
Original poster
Apr 9, 2003
Thanks for the replies! Got it figured out, was actually simpler than I expected.

Struggling with a new dissolve transitions problem, though. On some of my slides, as it cross dissolves there is a flicker. When playing the movie through, it looks like it's playing the first picture, dissolves to the second picture, then plays the first for a split second before continuing on with the second one again. When I look on the precision editor, my transition has 4 frames. In the transitions that look good, there is no change in the first frame, but frames 2 - 4 become progressively more like the second picture. In the transitions that look poor, frame 1 in the transition looks identical to frame 4 (where the second picture is more prominent). Oddly, I tried deleting and the reading the transition. Not only did this shift all later parts of my project one transition length earlier (4 frames earlier), but the "flicker" problem occurred in a different way. Instead of messing up by showing frames: 4, 2, 3, 4, it showed frames 2, 3, 4, 2. Sigh.

Yeah, that was complicated, so briefly:
Correct transitions: frames 1, 2, 3, 4
"flicker" transitions: frames 4, 2, 3, 4
Delete "flicker" transitions and put in new transitions: frames 2, 3, 4, 2 and project shifted one transition length earlier.

Any ideas on how to fix this?