Final Cut Studio 3 on PowerPC - revisited

Discussion in 'Digital Video' started by WayneH1, May 1, 2010.

  1. WayneH1 macrumors member

    Joined:
    Apr 28, 2010
    #1
    Thanks to the pioneers here, I've been able to install a mostly working set of FCS3 apps.
    http://forums.macrumors.com/showthread.php?t=755629&page=4

    In that older thread, only one thing in FCS3 was identified as Intel-only and therefore not functioning in this unsupported installation. But I cannot seem to use Share to Blu-ray functions either and I can't tell if it's just me. If anyone here is using FCS3 on a PPC machine, I'd appreciate hearing whether you can use the blu-ray options.

    Details and background: I was able to get an install of FCS3 to work nicely, except for the blu-ray problem, by two methods: using Pacifist or by using XCode to modify the install disk. Both methods gave me what appears to be the same result.

    The first step for either method is showing hidden files by entering the following Terminal commands, or by using TinkerTool.
    defaults write com.apple.finder AppleShowAllFiles YES
    killall finder
    Pacifist method: Then open the previously hidden Installer folder and find the Packages folder. Open all the packages there and install with Installer as many as you can, about 1/3rd of the packages. Use Pacifist to install the rest.
    XCode method: Use Disk Utility to convert the install disk image to one that you can edit. Show the contents of file "FinalCutStudio.mpkg" and locate the "FinalCutStudio.dist" file in the "Contents" folder. Open this with Xcode. Use the find function to locate the following line, and delete it.
    <installation-check script='installationCheck()'/>
    Save, and now Installer will run without balking about the lack of an Intel processor or too little VRAM.
    Finally, I had to edit the minsys.plist files for any app that required 128 Mb of VRAM, setting this down to 64 for my machine.
    If there's anythign else I might try for getting blu-ray encoding to function, let me know.
     
  2. needfinalcut macrumors newbie

    Joined:
    Sep 15, 2010
    #2
    minsys.plist is read-only

    Hello,
    I tried to change the VRAM requirement on the minsys.plist using Plistedit Pro but when I tried to save it, it said that the file is read-only and cannot be changed. Any way around this?
    Thanks!
     
  3. horosho macrumors newbie

    Joined:
    Feb 7, 2011
    #3
    workaround to "minsys.plist is read-only"

    needfinalcut,

    Use Disk Utility to create a new disk image from your FCP Install disc. If the Image Format is set to Read/write and Encryption to None, your resulting disc image will allow you to edit the minsys.plist.

    Credit goes to these instructions:
    http://www.lafcpug.org/Tutorials/basic_fcs3_macbook.html

    Cheers,
    horosho
     

Share This Page