Final Cut Studio - Leopard - G5 - Problems !!

Discussion in 'macOS' started by James0001, Nov 28, 2007.

  1. James0001 macrumors newbie

    Joined:
    Nov 28, 2007
    #1
    Anyone else running this ?

    I have a dual core G5 and have just installed Leopard and Final Cut Studio.
    Final Cut Pro and Color seem to work fine, but all the other apps start up with no serial number or version in the title card, and then open with a totally blank Apple menu (Bar across top of screen), which means I can't Quit or save or anything!

    Anyone know what the problem might be ? Something about permissions ??

    Cheers...

    PS I'm running all the latest updates, and have tried deleting the applications and reinstalling them !
     
  2. James0001 thread starter macrumors newbie

    Joined:
    Nov 28, 2007
    #2
    No one else having this problem ?
    Seems quite serious if you can't run FCS on a G5 with Leopard !
     
  3. LethalWolfe macrumors G3

    LethalWolfe

    Joined:
    Jan 11, 2002
    Location:
    Los Angeles
    #3
    Have you tried completely erasing the drive and installing everything from scratch?

    Whatever the problem it's most likely localized to your machine 'cause I haven't heard any major out cries from G5 users who've upgraded.


    Lethal
     
  4. Ted.t macrumors newbie

    Joined:
    Dec 11, 2007
    #4
    James - I'm having exactly the same problems as you so it's obviously not localised to your machine. I'm using a Mac Pro with the latest version of Final Cut Studio but only use FCS occasionally so have only just discovered the problem. I've installed the latest updates and done all the usual things but it makes no difference.
    As with you, Final Cut Pro works OK but Compressor and DVD Studio Pro don't work, with the same menu problems as you've described. When I mentioned this to an Apple Certified Professional trainer, he was horrified that I'd upgraded to Leopard, telling me that there were major problems with it, and suggested that I revert back to Tiger. Fortunately, I have a backup drive with Tiger installed, so I guess I can use that when I want to use FCS but I'm horrified that Apple's professional apps don't work properly in Leopard when Apple have had many months to get it right, and when all the other applications I have seem to work perfectly.
    The option of completely erasing the drive and starting from scratch is just not practical as it would probably take a week or more to get everything back to the way I want it. Even then, there's no guarantee it would work.
    It's been a couple of weeks since you raised this matter so I'm hoping that some answers have emerged in the meantime.
     
  5. Ted.t macrumors newbie

    Joined:
    Dec 11, 2007
    #5
    Further to my earlier post, I have spoken to an Apple Certified trainer who confirmed that it is a problem with Apple not getting FCS up to spec before releasing Leopard (blame iPhone). She advised me to do a completely fresh installation of Leopard and re-install FCS.
    I've just done this and have also done all the updates etc. Result - no improvement at all. As before, nothing works properly. Final Cut has some functionality but is still largely unusable. However, all the other apps, Motion, Live Type, Compressor etc have no menus and are completely unusable. Looks like we're stuck with going back to Tiger until Apple gets around to fixing the problem. A real black mark for Apple.
     

Share This Page