Final Cut X won't display or import files on external drive

Discussion in 'Digital Video' started by Minxy, Nov 19, 2014.

  1. Minxy macrumors member

    Joined:
    Nov 17, 2012
    #1
    Hi, I'm an amateur user of Final Cut X on a Mac Air 2012 128GB storage with 8GB memory and an external WD hard drive connected via USB 3. I make short, up to 15 minutes, videos.

    Obviously space on the computer is limited so I use the external drive to place my original video files and to create my Final Cut libraries and finished videos. The problem I'm having is that when I want to import video for a new film, CMD + I, then Final Cut Finder window doesn't show me the folder structure like it does when i search [my name] folder on the internal SSD. It just lists a random list of videos that are on the external hard drive and not the ones I want. This effectively means I can't use the external drive. It didn't alway use to be like this but I don't at what point it changed.

    I've been trying to find a solution and read that it may be related to having used the drive for Time Machine - which I did, but have since turned it off, but still no joy. Any ideas please?
     
  2. musique macrumors regular

    musique

    Joined:
    Apr 10, 2009
    #2
    A couple of things

    1. I've also been surprised on occasion when the Media Import window opens and things don't look exactly as they do in Finder. If you have several devices connected it usually remembers the last one you used. But even after I select the device I want I usually have to click on the column in the list of items to sort things so that they look like they do in Finder.
    2. Have you checked your Import Preferences?
     
  3. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #3
    I'm not sure why you're having a problem and can't solve it directly, but here's a workaround at least:

    Find the video files you want using Finder. Bring it up on the right side of the screen so you can still see your library and projects in Final Cut. Then I think you can select those files and drag and drop them on to your project in the library window. I believe that will pop up the import window and then you just change the setting to import without copying to the library.

    I don't have Final Cut here now to check so I can't promise this will work, but I'm fairly certain it does. I just never do this personally so I can't be positive. But give it a try.
     
  4. Zwhaler macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #4
    When you Command + I the window should look something like this

    Post a screen shot of what yours looks like. (Shift Command 3 or Shift Command 4 to take a portion of the screen)
     

    Attached Files:

  5. Minxy thread starter macrumors member

    Joined:
    Nov 17, 2012
    #5
    Hi Small White Car. I tried what you said and found that dropping the files into the clips section didn't work, but dropping them into the timeline added them to the clips, and then I delete them from the timeline. Thank you! :)


    Zwhaler. Here's a screenshot of when I press CMD+I
     

    Attached Files:

  6. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #6
    I think you have to go more to the left... over to the library. And I think you have to drop it precisely on the event, not just anywhere in there.

    I'm glad you fond something that worked, but I think you can save that extra step of deleting them if you find the right spot to drop it. It's over there somewhere!

    Is 'TM' the drive in question? (Or is there a missing drive?) What happens when you click on TM on the left there?
     
  7. Minxy thread starter macrumors member

    Joined:
    Nov 17, 2012
    #7
    I will try that again - I really am an amateur!

    My external has 3 partitions. PC, Mac and TM which is for Time Machine.
     
  8. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #8
    I assume the Time Machine is only backing up the data on the system drive?

    Also which version of FCP X are you using? The current version uses a new "library" to store your video and you don't see it unless you first do "File->Open Library" and then navigate to the library that is on the external disk.
     

Share This Page