Finally re-installed Leopard on new hard drive... can only boot from another computer

Discussion in 'macOS' started by c0bracommander, Feb 24, 2010.

  1. c0bracommander macrumors member

    Joined:
    Nov 5, 2008
    #1
    So I've gone through hell and back since my new hard drive replacement arrived. I was trying to burn my Leopard image (.dmg file) from my MBP to my iMac G5 PowerPC.

    After many unsuccessful rounds of burning to DL DVDs and flash drives, I settled on making my iPod bootable and running it from there.

    So I'm excited and running my startup disk on my MBP as the iPod and I've connected my MBP to my iMac G5 PowerPC through firewire and enabled target mode.

    After booting into the iPod, it gave me the option to install to the new hard drive from the iMac G5 (which is currently connected to my MBP). I installed it through my MBP, and assumed it had installed to my G5.

    After going through the initial installation, I powered down both machines. When I powered up the G5, nothing. I KNOW that Leopard is installed on it, but it's not recognizing it for some reason. I can only boot from my MBP, it seems.

    It's not a compatibility issue with the Intel/PPC thing either. At least I doubt it.

    Where do I go from here? I've been working on this for at least 7 hours.
     
  2. BobZune macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    USA
    #2
    That may very well be the problem. Since the G5's disk is "just a firewire disk" on the MBP computer (in firewire target mode), the installer may very well have installed the Intel version since the booting machine was MPB (guessing here, haven't verified).

    I'd suggest making a small, ~ 10GB second partition on the G5's hard disk and restoring the Leopard IMG file there (in FW target mode). Then booting from that partition (holding down option key and booting the G5 - not firewire target mode at this point). Good luck!
     
  3. c0bracommander thread starter macrumors member

    Joined:
    Nov 5, 2008
    #3

    You, sir, are out of control awesome. THANKS!!!!!!! It worked!
     
  4. c0bracommander thread starter macrumors member

    Joined:
    Nov 5, 2008
    #4
    Minor issue now. It's all installed on the computer, but it's only storing things to the partition I installed OS X to.

    There are (were) two drives mounted. The one with OS X on it and all the system files, and then the blank additional partition you suggested.

    I went into Disk Utility to get rid of the second partition (the blank one), which now has unmounted from the desktop, but it's still only using half of the entire drive.

    How can I enable the rest of the hard drive so that I may install the software updates? It currently won't let me as it has a 5.5 gb requirement and there isn't enough space on the partition that OS X is installed on.
     
  5. c0bracommander thread starter macrumors member

    Joined:
    Nov 5, 2008
    #5
    This is happening on my iBook G4 as well:

    [​IMG]
    [​IMG]

    Those are some screenshots to show what I'm talking about. How can I "re-claim" that additional space that isn't being used in the partition I got rid of?
     
  6. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #6
    What does the Partition section look like for your drive in Disk Utility? If the partition is still showing there, then delete it and drag your main partition down to extend over the whole drive size.
     
  7. c0bracommander thread starter macrumors member

    Joined:
    Nov 5, 2008
    #7
    Wow. I feel stupid. Worked perfectly. Thanks!
     

Share This Page