FINALLY! You can send mail from external address at MobileMe!!!!

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by SpaceJello, Jun 18, 2010.

  1. SpaceJello macrumors 6502

    Joined:
    Dec 2, 2006
    #1
    I have been waiting for this option for a long time but finally you can do this! This is definitely a tempting option to leave gmail with my own email address. :)

    Oh not to mention the other data plan options.... the 20 GB, 40 GB or 60GB of storage.
     
  2. mattmansfield macrumors newbie

    Joined:
    Sep 9, 2009
    Location:
    UK
    #2
    What a nice suprise this morning! This and the new rules feature means I'll finally be able to move the email on my domain to MobileMe. :D

    Now if only I could set my own email address as the default on my iPhone (instead of my MobileMe address) then I'll be happy. Anyone know if this can be done in iOS4?
     
  3. kultschar macrumors 6502a

    Joined:
    Mar 26, 2010
    #3
    Yep this is what I'm dying to know and will solve all my problems!
     
  4. danielbrowning macrumors member

    Joined:
    Jun 21, 2009
    #4
    If they can get this sorted, I'll get Mobile Me for me and my wife.
     
  5. sheikhsphere macrumors newbie

    sheikhsphere

    Joined:
    Mar 22, 2010
    #5
    I believe it is already been possible. You just have to change the outgoing sever of you MobileMe mail account to Gmail. Just like how you set it up on MobileMe.

    This is great news to me too! I'll be forwarding my Gmail to MobileMe from now on. Finally able to get "push" with Gmail .
     
  6. mattmansfield macrumors newbie

    Joined:
    Sep 9, 2009
    Location:
    UK
    #6
    That only seems to change the outgoing server. It doesn't set your own email address as the default when you compose a new email - that still defaults to your me.com address.
     
  7. sheikhsphere macrumors newbie

    sheikhsphere

    Joined:
    Mar 22, 2010
    #7
    I think you have to create your mail account on you iPhone using the "Other" method instead of "MobileMe". Then set incoming mail from MobileMe then out going to you Gmail smtp. And of course you can set your personal reply-to email address.

    Hope this helps. I've forgotten how I set it up a long time ago.
     
  8. mattmansfield macrumors newbie

    Joined:
    Sep 9, 2009
    Location:
    UK
    #8
    Good point, the only downside to this is that you'd lose push email though :(
     
  9. sheikhsphere macrumors newbie

    sheikhsphere

    Joined:
    Mar 22, 2010
    #9
    Oh Sorry I just checked. I have two separate mail accounts on my iPhone. A normal MobileMe then another "Other" account using Gmail and custom reply-to. So I set my default email as my "Other" account. I think for the iPhone we can only implement this with two accounts.
     
  10. tuna macrumors 6502

    Joined:
    Apr 11, 2010
    #10
    No way, I have my gmail pushing perfectly on my iPhone. And I also have my gmail account as the default account that I would automatically send from, in case there was still confusion over whether you could change the default account from MobileMe.

    To find instructions on how to set up Gmail for pushing, google search "google sync". You don't configure it through the normal "Gmail" setup in the iOS mail settings. On the older versions it was through "Other", and through the new iOS 4 its through "Exchange".

    To change your default email account, you go to Settings>Mail, Contacts, Calendars>Default Account
     
  11. sheikhsphere macrumors newbie

    sheikhsphere

    Joined:
    Mar 22, 2010
    #11
    Ok, to sum it up, using custom email with push on iPhone/iPod/iPad...

    Those with MobileMe service and want to use their custom reply to and custom push forwarding service, follow the link below:
    http://www.macosxhints.com/article.php?story=20080720093316215
    Just add MobileMe account, change outgoing to smtp.gmail.com. Then have your Gmail "send mail as" settings customize to you personal email. Its ok having a .me.com in your iPhone settings. it will still send as your custom email reply-to when using smtp.gmail.com instead of smtp.me.com.

    For those without MobileMe service would want to follow these:
    http://www.google.com/support/mobile/bin/answer.py?answer=138740&topic=14252
    Using exhange and google sync. I haven't try this though but it looks cool.

    Anyway I'm going for the MobileMe path, since we can send from a custom email using MobileMe now. :D
     
  12. attilahun macrumors newbie

    Joined:
    Jun 26, 2008
    #12
    Duplicate gmail messages

    OK, so the exhange setup is perfect and allows for sending gmails as default.

    My problem is now that I get duplicate emails from gmail since I setup mobileme to receive gmail via forwarding.

    Is there a way to turn off the receipt of gmail on the iphone 4 but still maintain the ability to send from gmail?
     
  13. danielbrowning macrumors member

    Joined:
    Jun 21, 2009
    #13
    This, with setting your personal domain in gmail as the default send, does work... But on Outlook (for example) it'll say that your emails are from "myusername@gmail.com" on behalf of "myusername@personaldomain.com". Doesn't look too professional sadly.

    I think Apple will need to give an option to send as your personal domain by default (this can be set already), and also obey that setting when sending via their smtp server (currently it doesn't seem to). Then we won't need to rely on external smtp servers.
     
  14. rtkane macrumors regular

    rtkane

    Joined:
    Apr 29, 2010
    #14
    Here's what I did to get it to work (at least with Comcast). I have everything forwarded to my MobileMe account and on my iphone, I've added an account under "Other" in the Mail, Contacts, Calendar settings.

    1. Click Add Account in Mail settings
    2. Click Other, then Add Mail Account
    3. On the New Account page, enter your mobileme account info. It will then look up your account and put you into an IMAP settings page.
    4. Under address, enter the email address that you want people to see (myusername@personaldomain.com).
    5. For incoming mail, enter email.me.com and your mobileme user/password
    6. Under outgoing mail, enter your personaldomain.com smtp server as well as whatever username and password you use for that. Click Next. It will verify your account information and on the next page will show IMAP at the top and give you options to choose Mail and Note syncing.
    7. Click Save. It will configure the sync.
    8. Back under the settings/Mail, contacts, calendar area, click the account you just set up and go into the account info tab. Click the outgoing mail server and on the next page make sure only the server your using for your domain is showing (this may be an optional step, not sure)

    Because the email is coming through as your personal domain (step 4 above) I don't think google forwards additional header information which cause the "on behalf of" message. I just tried it with my gmail and it works. This DOES NOT work if you add the account by clicking the "MobileMe" option under Add Account. It has to be done through other.

    And if for some reason I am wrong on any of this, apologies in advance--I've spent the last two days trying to get this working right and I believe the above is how I did it :)

    EDIT: Based on reply #8 above, this may not be using push email. It works well enough for me and syncs with all of my stuff, so if Push is important to you, it might not be the fix you need.
     
  15. danielbrowning macrumors member

    Joined:
    Jun 21, 2009
    #15
    It does everything except push, which I guess I'll just have to live without for now! That's great, thanks for the help :D
    I also like the way it'll save your emails to the MobileMe IMAP Sent folder, even though it's using your own personal SMTP server.

    I guess you've set up a seperate account for your MobileMe Calendar/Contacts via the usual MobileMe account method (leaving mail as unselected)?

    Aince I'm only on a MobileMe trial at the moment, and I assume this should work with Gmail too... I have to decide whether to use the free Gmail or pay for a MobileMe family account!
     
  16. monkeygadge macrumors newbie

    Joined:
    Jul 13, 2008
    Location:
    Scotland
    #16
    Problem with iPhone outgoing mail

    I've managed to get MobileMe to send out from [someone@mydomain.com] using my servers SMTP protocol (cPanel) by using the 'send using external address' in the web panel at me.com. It gives you the option to state the email address that you want to appear in the 'From' field.

    BUT

    Using an iPhone 4 with iOS4, you can enter new server details for outgoing mail but there is no option to state the 'from' email. This means all your outgoing email from your iPhone appears to come from [someone@me.com].

    I know that you can set another mail account on the phone then manually change the from address each time you send mail, but this is clunky and not ideal.

    Have I missed something? Does anyone know if there's a way to make sure all your mail from MobileMe on an iPhone comes from [someone@mydomain.com]?
     
  17. mrblack927 macrumors 6502a

    mrblack927

    Joined:
    Aug 19, 2008
    #17
    I'd like to know the answer to this as well. I got mobile me to send using my other domain's smtp server but it does indeed send it from "@me.com".

    It looks like it's getting that from the "address" field in the mobile me account settings. Of course, that field is greyed out so we can't change it :mad:. But I'm wondering if we can't go in the filesystem and change it manually via jailbreak...

    I'll post my results here as soon as I get my phone jailbroken. I have an iPhone 4 so who knows how long that will be... :(
     
  18. monkeygadge macrumors newbie

    Joined:
    Jul 13, 2008
    Location:
    Scotland
    #18
    I think this could be an omission from iOS4: what's the point in restricting it on mobile devices if you can easily set this up in mail and from the web interface?

    Is there somewhere you can submit issues to Apple for them to review?
     
  19. mrblack927 macrumors 6502a

    mrblack927

    Joined:
    Aug 19, 2008
    #19
    I could easily set this up from the web interface, but doing it in Mail is still clunky at best. Sure I can set up alternate SMTP servers to send from, but it's still difficult to set up multiple email addresses to send from. It's almost as bad as the iPhone's Mail client. I think Mobile Me is just (for once) too far ahead of it's App counterparts. Apple needs to propagate these changes down to the actual apps these services are supposed to interface with.
     
  20. Alonzo84 macrumors 6502a

    Alonzo84

    Joined:
    Dec 18, 2009
    Location:
    North Carolina
    #20
    I can not seem to get everything working as it should. I have a Gmail account and MobileMe account on my iPhone and in the Mail app on my Mac. Gmail is set to forward to me.com and archive the Gmail copy. I have both set to send from the gmail.com address, which works as it should. But when I send a test email to myself from my iPhone, it only shows up under my Gmail inbox on both iPhone and Mac, not under my MobileMe inbox. On me.com, they only show up under the SENT folder. I'm not sure what other settings I need to adjust to fix this issue.

    EDIT: If I send a test email to myself from a different account, they show up in the MobileMe inbox. Before, I was sending the test emails TO the same account I was sending FROM. For example, [abc@gmail.com] sent to [abc@gmail.com] does not get forwarded to MobileMe and shows up in the Gmail inbox. But [123@gmail.com] sent to [abc@gmail.com] is forwarded properly and shows up in the MobileMe inbox as well as showing up at me.com.
     
  21. Edward To macrumors newbie

    Joined:
    Jun 27, 2010
    #21
    I have the same problem as you. I have my Gmail set up as an external address on my MobileMe, and I access all my email through my MobileMe Mail app or Me.com. I cannot send emails to myself using my external email address; they only end up in the sent folder, but do get received in the Gmail inbox from which they are forwarded from.

    I too thought it was a bug, but perhaps it is just a limitation of sending from an external email address? I mean, what's essentially happening when we send email to ourself using an external email setup, is that we are writing an email which is sent from Gmail, which is forwarded to MobileMe, which then tells it to send back to Gmail, and forward to MobileMe once more. Maybe Gmail prevents it from being sent back and forth so many times, or else there would be an infinite loop?

    Just my personal guess. If anyone more knowledgeable would have any input on why we are unable to send emails to ourselves using external email address setup with MobileMe, please do let me know. I find it very useful being able to email myself reminders and such.

    Thanks,
    Edward
     
  22. JamesM macrumors regular

    Joined:
    Jan 27, 2007
    #22
    I just started a mobileme trial tonight and seem to have got it working quite well thanks to the tips on here. This is how my setup looks

    1. Personal mail forwards to mobileme

    2. Gmail account is set to send as personal address

    3. iPhone has mobileme incoming settings and gmail outgoing.

    Seems to work well its just a shame you can't get rid of the "sent by" added at the Gmail stage.

    Can anyone explain why Apple are making this so difficult, surely this could be integrated quite easily.
     
  23. Macsterguy macrumors 6502a

    Macsterguy

    Joined:
    Jun 5, 2007
    Location:
    Texas
    #23
    This may have already been answered. If so sorry...

    If your talking about send from in email... It does. I have 3 accounts. In settings on the phone you turn "on" show cc. After you do that you tap your own address in a email, then select the "send from"
     
  24. Alonzo84 macrumors 6502a

    Alonzo84

    Joined:
    Dec 18, 2009
    Location:
    North Carolina
    #24
    If you go to settings/mail, contacts, calender/default account/mobileme, sent and received emails will show up in MobileMe and be archived in the other mailbox (if set up that way). If you go to MobileMe under settings and choose account info/outgoing mail server/SMTP/smtp.gmail.com(or whatever account you wish to use) your message will show up as "from you@whatever.com" to the recipient even though your me.com address is displayed in the "from" field when you send the email. You don't have to change the "from" address before you hit "send".
     
  25. monkeygadge macrumors newbie

    Joined:
    Jul 13, 2008
    Location:
    Scotland
    #25
    I know this works for Gmail, however it doesn't work for all mail servers. I believe most servers will not 'change' the outgoing email address and leave the [whoever@me.com] address intact.

    BTW Last nights update to iOS 4.0.1 hasn't fixed this issue.
     

Share This Page