Find My iPhone - Always "Offline" [3GS]

Discussion in 'iPhone' started by freebird2003, Oct 16, 2011.

  1. freebird2003 macrumors member

    Apr 9, 2007

    I have a Jailbroken 3GS with iOS 5 [Baseband 04.26.08]. I have never tried Find My iPhone feature until now. I updated my Lion to 10.7.2 and created an Apple ID for iClould. I also used the same Apple ID on my iPhone to enable iCloud. I have turned off all other iCloud features except for Find my iPhone.

    When I login from my mac safari, My phone is listed under My devices but it is always offline. I have turned on 3G, Wi-fi and Location but despite numerous attempts, my iPhones is always stated offline.

    I have even tried the airplane trick, turning on and off but still no luck. I have also installed the Find My iPhone app. It starts of "Locating..." and later "No location avaliable" is stated.

    My map apps are working and all other location based apps are working and I am living in a country where GPS service is not banned.

    I have tried Find My Mac and it works. I could send message and play sound.

    Please advice.
    Thanks you.
  2. KentuckyHouse macrumors 68020


    Jan 29, 2010
    Lexington, KY.
    I could be wrong, but I think Find My iPhone is only intended for the 4 and 4S. I just came from a 3GS and IIRC, it never worked on the 3GS.
  3. freebird2003 thread starter macrumors member

    Apr 9, 2007
    Strange. I have seen several videos that Find my iPhone works on 3GS and even 3G models.

    It would be really great if someone could advice me on the "Offline" problem.

  4. GerMo macrumors member

    Nov 20, 2009
    I have been experiencing exactly the same problems. I could never locate my iPhone 3gs using Find my iPhone on iOS 5. I have made sure that all the settings regarding location services and find my iPhone have been enabled, but it just always appears to be offline.
    I started a thread a few days ago on this issue too.
  5. Applejuiced macrumors Westmere


    Apr 16, 2008
    At the iPhone hacks section.
    Yes, you're wrong.
    It works on the 3GS.
  6. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    It's either the jailbreak the baseband (most likely) or both. It does work on the 3GS
  7. freebird2003 thread starter macrumors member

    Apr 9, 2007
    Thanks for your reply. Is yours jailbroken too? It is really sad that we can't get FMi working. :(

    If the issue is caused by Jailbreak and/or old baseband, is there a tweak/patch in cydia to address this problem?

  8. freebird2003 thread starter macrumors member

    Apr 9, 2007
    Do you think by updating my baseband, I could get FMi working?
  9. freebird2003 thread starter macrumors member

    Apr 9, 2007

    Ok I have manage to get FMi working! (You phone must be jailbroken)

    Here is what I did.:

    1. Download iPusher App from App store. Test the push notification. If it says please wait even after few seconds, it means that push notification is not working on your iPhone.

    2. go to cydia and add repo url for the application SAM ("Subscriber Artificial Module"), google "Subscriber Artificial Module"; you ll find the repo URL

    3. install SAM and SAMpref

    4. Go to Settings > SAM and touch "De-Activate iPhone"

    5.Click "Revert Lockdownd to Stock" in Settings>SAM (its unactivating your Hacktivation)

    6. Connect with iTunes and activate it (ifs there a problem, google SAM homepage or tutorials for further instructions)

    7. If you already have "iPusher" app -> delete it

    8. Navigate to Settings » SAM » Utilities » tap on Backup Activation and then tap on Restore Activation label

    9. Reboot your iPhone and then sync it with iTunes

    10. Install iPusher App

    11. Reboot your iPhone and then sync it with iTunes. Make sure your iPhone is connected to a Wifi with an active internet connection

    12. Open iPusher app and tap on Test Push Notifications button. If you see a pop-up saying Yay, push notifications work fine! then it means your Push Notifications are working fine

    13. Now test FMi App, you should be able to send message and play sound and also location your iPhone.

    At this point, you can uninstall SAM


    Now I had this issue after i did the above, my iMessage always showed waiting for activation.

    Here is what I did : You have to restore your iphone again (No other solution). Use Redsn0w (Mac version) create custom firmware (Preserve Baseband.) Using Redsn0W put your iPhone to Special DFU and restore using that NO BB custom firmware. After that, jailbreak and deactivate your phone.

    After reboot, Your phone will activate automatically. Now my iMessage is working as well as FMi

    I hope it helps for anyone who have this problem. :)
  10. GerMo macrumors member

    Nov 20, 2009
    Thanks for sharing your success with us. But the thing is, my iPhone 3GS isn't jailbroken... It was previously carrier locked, and they helped me unlock it.
  11. freebird2003 thread starter macrumors member

    Apr 9, 2007
    Did you try iPusher App? Can you able to get a push notification?
  12. grimy macrumors member

    Jul 13, 2010
    Hey, I'm running into this problem on my 3gs and IP4. Thing is iPusher works for me so I don't see if its necessary to complete the rest of these steps. I posted up my progress on a post in the jb forum:
  13. zurlam macrumors newbie

    Jan 9, 2012
    Awesome tip! I had the same problem with iPhone 4 JB 5.0.1, and these steps worked just fine for me.

  14. ilipaskalev macrumors newbie

    Jan 22, 2012
    WHere do I get Cydia for Ipad? I bought my Ipad from Apple directly to work with all mobile providers (so I guess it's jailbreaked) but the find my iphone service doesn't work ... it always show offline.
    If I get Cydia, and do all above, will it also for for Ipad ?
  15. diegotoro macrumors newbie

    Mar 15, 2012
    My iPad is always "Offline" when I look for it.

    I gues this is a similar problem, but when I log in to the icloud, it shows my iPhone location regardless of whether it's awake or asleep. My iPad on the other hand always shows as "Offline if it is alseep. It will only show located if I open it up. Anyone have any idea why this is and what I can do to fix this? If it ever actually gets stolen or lost I would have to depend on someone waking it up before the cloud could locate it.


Share This Page