Find My iPhone - device not registered?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Dimwhit, Jun 17, 2009.

  1. Dimwhit macrumors 68000

    Dimwhit

    Joined:
    Apr 10, 2007
    #1
    Anyone else having trouble getting this to work? I turned the feature on on my iPhone, and I turned Push on, like they say to do. I even shut down my phone and restarted for good measure. I log onto my me.com account, but it says "no devices registered." Am I missing a step? I think I got it all, but it's just not working.
     
  2. Sir Pancakes macrumors member

    Sir Pancakes

    Joined:
    Dec 18, 2007
    #2
    I had the same problem. After deleting my mobile me account from the phone and then re-adding it, everything worked instantly. But I came to find that my mobile had not been syncing the last week or so. So dont choose, "delete data from phone" or you might lose stuff.
     
  3. Dimwhit thread starter macrumors 68000

    Dimwhit

    Joined:
    Apr 10, 2007
    #3
    I discovered my problem, and it was stupid. Wrong password. The thing is, when you enter the password into the mobile me account, it doesn't tell you if it's wrong, and there's no Save or Done button, so I didn't even know if it was being entered completely.

    Anyway, it finally works, and works well. Very nice feature addition to MobileMe.
     
  4. computermilk macrumors 6502

    Joined:
    Jun 10, 2008
    #4
    Yes i had this problem yesterday and i didn't even realize it but PUSH was turned off...

    Make sure Push is turned on.
     
  5. computermilk macrumors 6502

    Joined:
    Jun 10, 2008
    #5
    I'm very happy with mobileMe now.. i just wish that i could Publish my calender out without having to have a MAC and iCal... i have a windows PC... so i can't publish out my calender to other MobileMe people. =/
     
  6. balt macrumors newbie

    Joined:
    Mar 5, 2009
    #6
    Same problem here. It worked fine one minute, the next the phone had disappeared from me.com... no devices registered.

    I'm sorely disappointed with this feature. So no doubt any thief will know to simply disable either the push feature or remove the me.com account from mail settings... and voila, you can;t even remote delete the phone anymore, let alone locate it.

    They should have put some more thought into this.

    Gone are the days when apple developed software that doesn' suck.

    - Balt
     
  7. Dimwhit thread starter macrumors 68000

    Dimwhit

    Joined:
    Apr 10, 2007
    #7
    That's my issue with it. Sure, you can set a password to lock the phone, but I don't want to have to enter that every time I turn on my phone. Apple needs to put a password-lock feature on just the Find My iPhone setting, because you're right...all a thief has to do is turn that off when they first get the phone. Not exactly anti-theft security.
     
  8. fredoviola macrumors regular

    Joined:
    Oct 20, 2008
    #8
    I'm having the same problem, but I do have PUSH turned on, FIND MY IPHONE enabled, and I'm quite sure I entered my password correctly. Actually, I had mistyped my name and the phone did warn me that either my name or password were not inputted correctly. What could be the problem???
     
  9. shabbz23 macrumors newbie

    Joined:
    Mar 20, 2011
    #9
    How I Fixed It...

    Dimwhit,

    I received my iPhone 4 as a gift last month and registered it for the free Mobile Me account, which worked great. I was able to use Find My iPhone A-OK. Then I exchanged that iPhone for one with higher storage, and the Find My iPhone account stopped working. It could not locate my phone. I figured it had to still be connected to the first device I had purchased, so at the Find My iPhone website, I deleted the first device. I tried to register my current phone and only got a message that said Device Not Registered when I tried to check on the site to see if it worked.

    Like you, I tried everything that Apple recommended -- several times! Finally, I figured out that what you need to do -- what worked for me anyway -- is delete your Mobile Me account from your iPhone. Re-add it, but right after you re-add it, PRIOR to pushing save, switch your Find My iPhone to OFF. Then Save it with Off selected (to where it will not allow Find My iPhone). After you've saved it, switch that button to On, and you will get a confirmation at the bottom of your iPhone screen asking to Allow the Find My iPhone to use your current location and blah blah blah, and then you click Yes, and you should be good to go!

    It took me such a long time to figure out because when I would re-add the account, On was already selected to allow it, and I'd just push Save. Then when I was trying to switch it to Off (because Apple recommended this to troubleshoot this problem), the switch would go to Off for a split second and automatically go back to On. I'm not sure why it did this, but it took me having to initially save the account to NOT allow it in order to eventually get this to work. In other words, slide your button to Off BEFORE you push Save, then change it to On after; try that.
     
  10. breathofj macrumors newbie

    breathofj

    Joined:
    Mar 22, 2005
    #10
    Just wanted to say thank you for this post. I was getting extremely frustrated with my wife's new iPhone 4 (as was she), but this solved the problem before she ended up throwing the new 200 dollar device out the nearest window. :)

    Thanks for posting!
     
  11. LKP101 macrumors newbie

    Joined:
    May 10, 2011
    #11
    You are a GENIOUS!!!! Thank you Thank you!!!
     
  12. kwk1 macrumors regular

    kwk1

    Joined:
    Aug 30, 2008
    Location:
    Canada
    #12
    Thank-you shabbz23!!!!!!

    I had it too.
    No Location Available.
    Spent 40 minutes on the phone with Apple,
    only for them to tell me to purchase an app, it might work better.

    I followed your instructions,
    and it now works perfectly.

    Thank you very much!!:D
     
  13. Spitfire411 macrumors member

    Joined:
    Mar 28, 2011
    #13
    I can also confirm this works. I had originally set the service up on an iPad 2 but had it exchanged at the Apple store. After trying to set up the service on my new iPad, it didn't work.

    Just hit cancel when it says " Find My iPhone will display your device on a map" (paraphrase) and then turn the switch to ON manually. Great job figuring this out! Thanks!
     
  14. sgjohnston macrumors newbie

    Joined:
    Dec 14, 2009
    #14
    Unblock TCP port 5223

    I just spent an hour with Apple on an online support chat because I couldn't get my iPad to show up in Find My iPhone (even though my iPhone shows up fine). Eventually I tried a full reset of everything, and still not luck :-(. The support guy was stumped, and said he would escalate it.

    However, after the chat session I had a flash of inspiration and checked my firewall log - and connections to TCP port 5223 (to an Apple address) were being dropped. I opened up that port on the firewall, and voila, instantly the iPad showed up in Find My iPhone. It turns out that TCP:5223 is used for Mobile Me sync things (although most of Mobile Me seems to work with it blocked). I wish I had thought of that before wiping the iPad!

    Just in case anyone else is faced with the same frustration...

    Stuart
     
  15. jinx1959 macrumors newbie

    Joined:
    May 24, 2011
    #15
    find my iphone

    Do I need a MobileMe account to use the find my iphone feature. I set everything up like it said to but it shows that there are no devices registered. please help me if you can. send to my email the answer



    wyattchristopher02@gmail.com
     
  16. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #16
    Yes, you need to setup a free mobileme account using an i4, new ipod touch, or ipad.
     
  17. jinx1959 macrumors newbie

    Joined:
    May 24, 2011
    #17
    find my iphone

    never mind i tried what shabbz23 said to do and it works great now thanks to those of you that replied and thanks to shabbz23
     
  18. jinx1959 macrumors newbie

    Joined:
    May 24, 2011
    #18
    apple tv issues

    im looking for someone that might be able to help me with an issue i am having. my macbook pro wont airplay movies to the apple tv and the movies wont show up on the apple tv menu under computers but all of my music and music videos do. can anyone answer this
     
  19. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #19
    Start your own thread in the right section of the board.
    This is the iPhone section and this thread is about the find my iPhone feature.
     
  20. alexmelodymaker macrumors newbie

    Joined:
    May 29, 2011
    #20
    It works!!!

    This is it, guys. Tried and true method that enables, reregisters and locates your phone on mobile.me.

    Thanks thousands for this!
     
  21. djkevo macrumors newbie

    Joined:
    Aug 11, 2011
  22. djkevo macrumors newbie

    Joined:
    Aug 11, 2011
    #22
    This works!!! Great
     
  23. corbinns1 macrumors newbie

    Joined:
    Aug 13, 2011
    #23
    Thank you very much!!!!

    Thank you very much for you help, this simple yet smart fix made my day. I was on the phone with apple for thirty minutes trying to explain to the the issue... all they wanted was $29.00 to give me a one time fix.
     
  24. TashTash macrumors newbie

    Joined:
    Sep 7, 2011
    #24
    Thankyouthankyouthankyouthankyou!!!


    You are a genius! thank for posting this, nothing else seemed to work!
     

Share This Page