"Find My Mac" requires running as an administrator

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by thewhitehart, Oct 8, 2011.

  1. thewhitehart macrumors 6502a

    thewhitehart

    Joined:
    Jul 9, 2005
    Location:
    The town without George Bailey
    #1
    The "Find My Mac" feature in iCloud (Lion 10.7.2) requires a user to run as an administrator. I prefer running as a standard user, but I want this feature on.

    Haven't found any workarounds yet, other than setting up iCloud with my Apple ID on my mac's administrator account.

    Anyone with any ideas for a workaround?
     
  2. brijazz macrumors 6502

    brijazz

    Joined:
    Jul 31, 2008
    #2
    +1 to this question. I run as a standard user also (for security reasons, primarily) but don't want to lose out on the "Find My Mac" functionality.
     
  3. RafaelT macrumors 65816

    RafaelT

    Joined:
    Jun 9, 2010
    Location:
    Lakeland, FL
    #3
    Glad I was not the only one stumped by this. I don't understand why I can not authenticate to enable this. I tried running it on my admin account but when I logged out it stopped working.

    This is lame.
     
  4. user418 macrumors 6502a

    user418

    Joined:
    Aug 22, 2010
    #4
    I use my admin account the majority of the time. I can't enable find my mac on my desktop. It states a recovery partition is required. My iMac is a 2010 21.5" 3.2 ghz core i3. I previously made a usb Lion Recovery Disk Assistant in case I ever needed it but would like to enable the find my mac feature. Am I missing something or is this just not possible. The feature works fine on my 2011 MBP. Any help would be greatly appreciated. Thanks in advance.
     
  5. brentg33 macrumors 6502a

    Joined:
    Mar 5, 2007
    #5
    same here. Logged into the admin account....enabled it. logged back into standard user and its grayed out. Got to be a way to do this.
     
  6. petergarner macrumors newbie

    Joined:
    Oct 14, 2011
    #6
    A solution: Lion Recovery Update

    I solved this problem by downloading the Lion Recovery Update, which as far as I can tell is only available to admin accounts. Just log in to admin and run software update. The LRU should appear. Download it and then enable Find My Mac in the iCloud preference pane in the admin account. After that, FMM should work for that computer (even though it's greyed out in the standard user account). For some reason, even if the FMM checkbox in the iCloud preference pane is checked, you need the LRU to make FMM work, so if you enabled FMM on the admin account before downloading the LRU, you'll have to uncheck and recheck the FMM box before it will work.

    Strangely, when I set up FMM on my desktop (mini), there was an "update" button beside the FMM item in the iCloud preference pane (in the admin account). Hitting the update button downloaded the LRU. But on my old MBP (2007), there was no update button. I had to manually run Software Update to get the LRU. But after that, FMM seems to be working.

    Hope this helps.
     
  7. zvandiver macrumors member

    Joined:
    Feb 3, 2008
    #7
    I am running into a similar issue. I had no problem enabling Find My Mac on my 2008 Macbook that I now use as a desktop, but I cannot get it to work on my Macbook Air. I am logged in as admin, and the update button is next to the iCloud panel, but when I run software update, it says I am up to date. I downloaded the recovery update and installed it manually, and I still cannot activate Find My Mac on my Air.
    Are there any other suggestions to get this working.
    Zane
     
  8. zvandiver macrumors member

    Joined:
    Feb 3, 2008

Share This Page