Finder and other programs crashing when viewing certain JPGs

Discussion in 'Mac Basics and Help' started by munkeyq, Jul 22, 2010.

  1. munkeyq macrumors newbie

    Joined:
    Jul 22, 2010
    #1
    Hi everyone. I've got a problem with my Mac - it's a 2.1ghz Macbook (not the new type, the polycarb one) running Snow Leopard 10.6.4 and all of the latest updates. Well, apart from the newest iTunes version as for some reason it won't let me install that...anyway.

    Whenever I open a folder with a large number of JPGs in it (about 300, 700mbs worth) in Finder, it only loads that screen of thumbnails. Scrolling up and down will crash Finder for about 3 minutes until those thumbnails load. Trying to Quick Look any of those images will crash Finder completely and bring the whole machine to a standstill with the spinning pinwheel - in the end, it will quit with a EXC_BAD_ACCESS (SIGBUS) message.

    This has only started happening recently. At first I thought it was a problem with Finder, but if it's causing other apps to crash then it's something else...

    Opening any of the images in that folder with an app such as Xee will cause that app to crash with the same message.

    I've done these things so far:
    - Delete preference files
    - Clear all DSTOREs from the boot volume
    - Reset SMC

    Looking at the problems other people have had, it points toward possible bad RAM although the BAD ACCESS message seems to be fairly generic.

    I've had a Mac for about a year now and I can't count how many problems I've had like this. Most of them have been solved by Google-ing the symptoms, but I'm at a dead end with this. The last Software Update prevented the machine from booting past the loading screen so I've already had to reinstall once. In the two years before I had my Dell with XP, I never had any problems, however small...and I've had to hard power down this thing due to software crashes more times than the Dell. If these problems are part of Mac ownership, it's a shame as I really like it, but I'm going back to XP otherwise.


    Thanks for any help you may be able to offer!


    Edit - here's the Finder thread which crashes:

    Thread 6 Crashed:
    0 libSystem.B.dylib 0x00007fffffe00b31 __memcpy + 913
    1 com.apple.ImageIO.framework 0x0000000103e2403b CGImageReadGetBytesAtOffset + 461
    2 com.apple.ImageIO.framework 0x0000000103e23e63 CGImageReadSessionGetBytes + 35
    3 com.apple.ImageIO.framework 0x0000000103e3349c fill_input_buffer + 190
    4 libJPEG.dylib 0x00000001050cc8e8 decode_mcu_optimized + 2805
    5 libJPEG.dylib 0x00000001050cbc00 decompress_onepass + 138
    6 libJPEG.dylib 0x00000001050dc094 process_data_simple_main + 76
    7 libJPEG.dylib 0x00000001050cbb5f _cg_jpeg_read_scanlines + 172
    8 com.apple.ImageIO.framework 0x0000000103e3d057 copyImageBlockSetJPEG + 3063
    9 com.apple.ImageIO.framework 0x0000000103e274a8 ImageProviderCopyImageBlockSetCallback + 189
    10 com.apple.CoreGraphics 0x00000001036a96c2 img_blocks_create + 356
    11 com.apple.CoreGraphics 0x00000001036a9533 img_blocks_extent + 96
    12 com.apple.CoreGraphics 0x0000000103734da8 img_interpolate_extent + 137
    13 com.apple.CoreGraphics 0x000000010367410a img_data_lock + 8478
    14 com.apple.CoreGraphics 0x00000001036712ef CGSImageDataLock + 212
    15 libRIP.A.dylib 0x000000011b859227 ripc_AcquireImage + 2431
    16 libRIP.A.dylib 0x000000011b857aa9 ripc_DrawImage + 1208
    17 com.apple.CoreGraphics 0x000000010368c11a CGContextDrawImage + 446
    18 com.apple.qldisplay.NSImage 0x000000011e04b27b 0x11e049000 + 8827
    19 com.apple.QuickLookFramework 0x0000000101085642 QLCreateImageWithBlock + 83
    20 com.apple.qldisplay.NSImage 0x000000011e04bb83 0x11e049000 + 11139
    21 com.apple.Foundation 0x000000010225de8d __NSThread__main__ + 1429
    22 libSystem.B.dylib 0x0000000101cd8456 _pthread_start + 331
    23 libSystem.B.dylib 0x0000000101cd8309 thread_start + 13
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    If every app you try to open the JPEGs with crashes, you've either got corrupt JPEGs or something wrong with the disk. The Finder is crashing for the same reason--when it tries to generate a preview of the JPEG (by reading it) it crashes on the bad file.

    Start by checking your drive for corruption or directory errors: Boot the machine using the latest OS install discs you have, select Disk Utility from the menu in the installer, and to a Repair Disk.

    If it comes up with problems and fixes them, see if that solved the issue.

    If nothing comes up, either the JPEGs got corrupted along the line somewhere (are you sure they were originally ok?) or there are hardware problems with the drive. Back up immediately, just in case, and try to get your hands on a 3rd party program to do a full surface scan of the drive and see if anything comes up.

    If problems come up and Disk Utility can't fix them, you've either got severe corruption or a dying drive--back up immediately, and then either reformat and reinstall or try a 3rd party utility to repair the corruption. If it comes back immediately or other weird things happen, probably bad hardware.
     
  3. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    Don't know if you've tried my suggestions yet, which I'd still start with, but thinking about it more and based on your description of several other issues--in particular failed SW updates and multiple system-level crashes--you may be correct that you have bad RAM or another hardware problem. That kind of stuff just doesn't normally happen with a Mac unless there's either a hardware problem or you're running some particular system add-on that is buggy.

    I can't figure out why opening particular JPEGs would trigger a RAM-related crash, but who knows--bad RAM can cause just about anything imaginable to go wrong.

    Have you tried running the Apple Hardware Test? It'll be on the original install discs, and while it's not perfect it's easy enough to run a full hardware scan and see if it comes up with anything. Memtest is another thing you could try; Rember is a free Mac GUI for it:
    http://www.kelleycomputing.net/rember/
     
  4. munkeyq thread starter macrumors newbie

    Joined:
    Jul 22, 2010
    #4
    Thanks for the replies.

    I ran a surface scan on the drive, which didn't reveal any errors. I then ran Disk Utility off the DVDs, and sure enough it came up with errors so I hit Repair.

    All was good until I rebooted - the repairing seems to have completely removed all the photos in the folders where it was crashing. Well, I suppose that's one way to prevent the crashes...just wipe it clean! :eek:

    I'm running a couple of file recovery programs now to see if the data has been overwritten or not. The files aren't anything critical but it would be nice to get them back and save the effort of taking them again.

    The hardware tests all ran smoothly and didn't reveal any problems with disks or RAM though.

    Also, I forgot to mention - the photos could be be moved from the folder to a new folder via the Terminal, but copying them to another drive kicked up an error -32 every time. This made me think it was a disk failure.

    I've got some more problems which have sat there from day 1 and apparently are pretty common, so if you guys don't mind, I'll be making a few more begging for help threads soon!
     
  5. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    Begging for help is of course the point of this forum so go to.

    As for your photos, the problem presumably was that they in effect weren't there but looked like they were, which is why repairing the disk caused them to vanish. Good luck with file recovery--Data Rescue 3 is the one to try:

    http://www.prosofteng.com/products/data_rescue.php

    ...and you can see what it'll find and recover a test file for free, before deciding if you want to pay. Do remember that the more you use the computer, the lower your chances of recovery get.

    I would also suggest you keep an eye on things--disk corruption that severe is exceedingly rare on a modern computer. Could've just been bad luck--I've seen other people with luck that bad--but it could also be a sign of a flaky hard drive, even if everything says it checks out ok. Not necessarily worth chucking a perfectly good drive to be sure about, but keep an eye on it for other odd behavior (and make sure you have current backups--which you should ALWAYS do).
     
  6. munkeyq thread starter macrumors newbie

    Joined:
    Jul 22, 2010
    #6
    Thanks again for the reply. That utility was the first one I tried and it didn't bring anything back. Ah well... Oh, and the drive is fairly new as well, and it's not showing any other signs of corruption.

    I back up stuff to a Firewire drive weekly, but unfortunately this happened just after a backup.


    However, I think I'm going back to Windows. I've exclusively bought used Dell Latitude laptops for the past 8 years and I haven't been let down by the hardware or software yet, touch wood. I changed to a Mac for Logic Pro, but with the constant troubles I've been having just isn't worth it unfortunately.
     

Share This Page