Finder broken after upgrade to 10.5.2

Discussion in 'macOS' started by carcaman, Feb 23, 2008.

  1. carcaman macrumors newbie

    Joined:
    Feb 23, 2008
    #1
    Upgrading to 10.5 was painful... The Time Machine started copy backup to one of my external disk without asking, at which point I panicked (didn't have time to wait for over 3TB that were connected at that time to be backed up to 1.5GB I had free, just to bbomb at the end). Turned off the machine (it was already in an unresponsive state), and when I restarted everything seemed to be normal again (Time Machine did not even show up).
    A few days later, Aperture 2 protests that it needs 10.5.2 to run (???it did OK before with 10.5.1). So, I just upgraded the OS to 10.5.2... and now the Finder is broken:
    * Disk icons are gone from my desktop
    * I can start apps from the Dock, and their menus will work. But none of the Finder menus works
    * Force Quit Apps shows up, but it doesn't work when I select the Finder
    * System Preferences show up, but don't work when I try to select a pane.
    * Only way to shut down is shutting down the power
    * I run LaunchBar, as a way to get to applications inside my disk, but any dialog that makes references to files freezes
    * I ran TechTools Pro, and all the disks seem to be OK (except one that says that Finder Info is not correct -- but when I ask it to fix it it can't).

    So, I'd like to boot from the OS X 10.5.1 DVD, but I can't open the drive. This is looking quite lame, considering how well the system was running before 10.5. Can somebody help? I am quite desperate, with files locked in the machine that I need to deliver today :(
     
  2. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #2
    Don't turn off the machine when Time Machine is running, it would have failed gracefully ;).

    So others can help more (I'm off to bed) what Mac have you got?
     
  3. carcaman thread starter macrumors newbie

    Joined:
    Feb 23, 2008
    #3
    Sorry, should have provided...
    G5 Quad Processor, 2.5 GB memory, two Cinema 30 displays, two internal drives (600 Gb total), four 1TB external disks, Quadro 4500 Video card

    Thanks for replying! Have a nice night of sleep :)
     
  4. carcaman thread starter macrumors newbie

    Joined:
    Feb 23, 2008
    #4
    Can some body please help?

    I am still having the problem...

    Tried selectively turning off external drives, tried running disk utilities, no luck. The center of my current effort is to open the DVD drive so as to boot from the original OS DVD (and hopefully be able to go back to 10.4, because 10.5 has been nothing but pain so far).
    Tried starting up with the mouse button pressed, but the drive did not open. Anybody knows a reliable way of opening the DVD to boot from an OS disk?

    And also, if I have 10.5 installed, can I boot from 10.4 and revert to 10.4?

    Please help, every time the machine is turned off and on something else is damaged...
     
  5. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #5
    Time Machine wouldn't start backing up to a drive without you telling it it is OK to use that drive as a Backup disk.

    Also, try searching the forums, there is a ridiculous amount of posts about 10.5.2 breaking things.

    The most common solution is downloading the Mac OS X 10.5.2 Combo Update.

    That reinstalls all previous updates as well as 10.5.2 (god, this is like the 10th time I've posted that solution in the past few days).
     
  6. carcaman thread starter macrumors newbie

    Joined:
    Feb 23, 2008
    #6
    Thanks

    What I actually did was find out how to open the DVD (most big problems usually start with a small step). (Open Firmware helped) Now I am in the process of reinstalling 10.4. I will wait until 10.5.X is usable. Not the first time that I've been hurt by Apple's poor software life cycle.
    You sounded irritated, I am sorry to have contributed to that. By the way, the link you posted doesn't work.
    Be well
     
  7. carcaman thread starter macrumors newbie

    Joined:
    Feb 23, 2008
    #7
    Nope, the old CD does not install even when I boot pressing C. It freezes at the Grey apple screen. So, I re-installed 10.5... Same thing :( Finder not working.

    Is there a reliable way to force the Finder to re-launch, IF I don't have access to the disks, and Terminal doesn't work?
     
  8. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #8
    Sounds like dodgy RAM rather than Leopard.

    You did a clean reinstall and installed all the updates and it still doesn't work properly?
     
  9. carcaman thread starter macrumors newbie

    Joined:
    Feb 23, 2008
    #9
    Yes, clean reinstall of 10.5 (archived the old 10.5.2 as suggested by the installer)
    No, no updates installed because upon reinstalling 10.5 I have no finder.

    Can you clarify for a dense guy like me what you mean when you say "dodgy RAM"?

    BTW, thanks for keeping at it, I greatly appreciate it :)
     
  10. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #10
    Well, mis-aligned RAM would more likely trigger kernel panics than anything else but worth checking out anyway.

    I'd take your Mac to your nearest Apple store if possible.
     
  11. carcaman thread starter macrumors newbie

    Joined:
    Feb 23, 2008
    #11
    Before I do, and since you mention RAM: is clearing the PRAM something worth doing in this situation? I have no idea about the implications, but browsing around I found lots of mentions of that...
    Cheers!
     

Share This Page