Finder broken and can't enter my Installation Disc

Discussion in 'macOS' started by Ultimedia, Jul 11, 2010.

  1. Ultimedia macrumors newbie

    Joined:
    Sep 20, 2009
    #1
    Dear Macrumors Members

    I am a Mac user for years and I have some experience with troubleshooting and fixing/reinstalling Mac systems unfortunately I feel rather hopeless at the moment since I wasted hours and hours on trying to fix my 4months old iMac (the 27" edition).

    Ok so first of all, the problems appeared after some Apple updates, (it was a few months since my last update), I installed the updates and restarted my system and suddenly finder was broken, it just freezes all the time and I can't seem to open it and browse through my files and when I force quit it just crashes again.

    The only thing I can is use spotlight to browse for something (note that applications like iTunes and Photoshop work perfectly).

    Feeling desperate in this situation I tried to reinstall my Mac, so I inserted my Mac Install discs and pressed the ALT key while booting. The disc appeared but when I press enter my iMac just freezes and doesn't do anything. I tried a PRAM reset at this moment but that didn't do it either. I even tried different versions of Mac installs but with the same result. In the end I even tried to run my Discwarrior boot disc but it also crashes. So I can't seem to boot anything except my messed up Snow Leopard install.

    Note that I also tried booting from an external hard drive but with the same result.

    At last I tried booting in single user mode and I used the "fsck -y" commando but that gave me some Disc Errors.

    Ok lets get things clear, I want to format my Macintosh HD and peform a clean install, what should I do :)?
     
  2. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #2
    If you can't boot to an installation disk (have you tried the "C" key method?) then I suspect you have faulty hardware.
     
  3. Ultimedia thread starter macrumors newbie

    Joined:
    Sep 20, 2009
    #3
    Yes, I also tried the C method, well I don't think it's hardware because I have a working Windows 7 partition installed (I can play games on it without problems).
     
  4. Hailfire753 macrumors newbie

    Joined:
    Jun 10, 2010
    #4
    Same thing just happened to me, for no apparent reason, and I literally fixed it minutes ago. Finder would crash, and eventually the comp would not boot at all. I did not use the recovery CD, so I did not notice that issue.

    I could hold down option and boot to bootcamp or select an external drive.
    fsck -y gave me some error about key files that could not be repaired. It did not work.

    I pirated snow leopard, so I actually wrote the .iso file I downloaded to make a bootable partition on an external drive, since I did not have any double layer dvds. I selected this partition, and got the recovery cd to work that way. I tried restoring from time capsule. When the backup booted after an overnight transfer, it did the same thing; when the computer booted it froze at the gray or blue screen. Next I reinstalled snow leopard, and now it works.
     
  5. Ultimedia thread starter macrumors newbie

    Joined:
    Sep 20, 2009
    #5
    @Hailfire753

    Thanks for the info but I also tried using a partition with a restored iso in it, no luck, I press enter in the boot menu, I see the Apple and nothing happens (I waited like 30min and nothing).
     
  6. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #6
    What does this mean to you?
     

Share This Page