finder cannot launch application; help!

Discussion in 'Macintosh Computers' started by Cecret, Feb 25, 2005.

  1. Cecret macrumors member

    Mar 1, 2003
    I'm having a strange problem.
    ibook g4 800
    640mb ram
    30gig hdd 14gig used
    os 10.3.8

    My computer will work fine for a day or two -- I can have numerous programs running at the same time with osx stability -- but if I do not restart it at some point something happens and when I try to open an other application I get an error message saying:
    "Cannot launch application (insert app name here) -10810"

    I can open the app as long as I quit some or all of the other open apps. This will usually happen with only mail and safari open and I will try for example to open itunes or address book. I shouldn't be overloading the system because if I do a restart problem solved for about 24hours -- I can have everything open at once.

    I talked to apple tech support and they told me to reset the pram, check disk permissions, and run a hardware test. All with no luck. They then advised me to run the hardware test in looping mode overnight and still no errors showed up. They think it is a ram problem. I tried running on just the built in 128mb chip (removing the 512mb chip I got from crucial a year ago) but it wasn't enough memory to cope with normal use.

    I don't want to spend the money on a new 512mb ram chip just to trouble shoot a potential problem. Anyone have any ideas???
  2. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    Two more things to potentially try are:

    1) Delete or rename your finder prefs file (~/library/preferences/ and then restart Finder or reboot. (For that matter, have you ever tried 'relaunch finder' from the force quit dialog, to see if this has the same effect of temporarily returning you to normal, as rebooting does?)

    2) Reinstall the OS..... :( In a way, probably, that avoids letting files from either /library or ~/library get back onto the computer....

Share This Page