Finder Closes when I try to open Macintosh HD

Discussion in 'macOS' started by jb4647, Jun 30, 2010.

  1. jb4647 macrumors newbie

    Joined:
    Jun 30, 2010
    #1
    I've just noticed this happening tonight. I did perform todays Mac Update but I don't know if they are related.

    Whenever I try to open "Macintosh HD" (my boot drive) the Finder closes. Does anyone know what the solution could be?

    I was able to run a "verify disk" and it said there were errors so I did a reboot to my Snow Leopard start up disk and was able to repair the errors.

    This problem is still happening. I've googled everything I can think of and can't seem to find anyone else with this issue. I'd rather not have to reimage the machine.

    Upon further investigation I've noticed that the problem seemed to have started on June 20th. I can access the back-up folders of my Time Machine for "Macintosh HD" for all dates prior but starting on the 20th if I try to access the Macintosh HD backup folder, Finder shuts down just as it does with the current Macintosh HD.

    I can't believe this hasn't happend to anyone else
     
  2. Erendiox macrumors 6502a

    Erendiox

    Joined:
    Oct 15, 2004
    Location:
    Brooklyn NY
    #2
    Sounds like the beginnings of a bad hard drive to me.
     
  3. jb4647 thread starter macrumors newbie

    Joined:
    Jun 30, 2010
    #3
    Even if I can access my home folder with no issues? My home folder resides on Macintosh HD.

    Is there a harddrive test/scan I can run?
     
  4. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #4
    Open "Disk Utility" and click on your hard drive, then run "Repair Disk" and see what it says once it has finished.
     
  5. MacTech68, Jul 1, 2010
    Last edited: Jul 13, 2011

    MacTech68 macrumors 68020

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #5
    If you're certain the directory structure is sound (via Disk Utility verify) then the only thing I can think of is a corrupted .DS_Store file at the root directory of your Hard Drive.

    The file is invisible, since it's prefixed with a dot. There are several ways to deal with it, including;

    In Terminal, change to the root directory;

    cd /

    Next, delete the file;

    sudo rm -rf .DS_Store

    enter your administrator's password when prompted.

    That might fix it.
     
  6. jb4647 thread starter macrumors newbie

    Joined:
    Jun 30, 2010
    #6
    I did that last night and it found several errors and fixed them yet the problem still occured. Thanks for the tip!


    I'll try this out when I get home. Thanks!

    I just moved to the Mac after 15 years using PCs....I thought they wern't supposed to have issues like this!
     
  7. jb4647 thread starter macrumors newbie

    Joined:
    Jun 30, 2010
    #7
    I think I fixed it

    I tried the deleting the .DS_Store and that did't work.

    Upon further research, I deleted com.apple.finder.plist and that seemed to do the trick. I'm now able to view the contents of Macintosh HD.

    A couple of funny things though.

    • I'm not able to see anything but in the icons view, trying to change it to list, coverflow or columns shuts Finder down.
    • In addtion to my normal system folders there are several files with gibberish names. I'm curious as to if these are normal files. I've included a screen capture below:

    [​IMG]

    What do you all think?
     
  8. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #8
    You must have gotten the only bad apple in the bushel. No one else has ever had a Mac problem. :rolleyes:

    I hear the same is true of Toyota automobiles.
     
  9. MacTech68, Jul 1, 2010
    Last edited: Aug 25, 2011

    MacTech68 macrumors 68020

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #9
    Hmmm.. looks like whatever directory corruption you got might have been fairly serious. Can you copy those gibberish files (6 in total) to another drive, and then delete them from your boot drive? Once you have the gibberish files on another disk, pop them into a folder and see if you can do a "list view" and see what sizes they are. Post another screen grab. This time, upload your image as an attachment - it will thumbnail the image in the forum. :)

    Once you've done that, reboot and hold down the ("Apple" and "S") keys. When you get a screen of text, type:

    fsck -fy

    Note the 'space' and 'minus' in font of 'fy', and let us know what errors (if any) it finds. If it does find errors, type

    reboot

    and do the same again (holding down "Apple" and "S"). If it still reports errors on the second try, you're in trouble. Might be time to get local help. :eek:
     
  10. jb4647 thread starter macrumors newbie

    Joined:
    Jun 30, 2010
    #10
    Very odd

    After going out of town this weekend I tried to get a file size of that gibberish to no avail. Any folder that those files are in closes down the folder. I burned them to a blank DVD and from the burn tracks on the bottom of the dvd it looks like about a gig of space used. Browsing the dvd shuts down finder. Wild.

    So then I proceeded to put the dvd into one of my Windows laptops and guess what? Immediate blue screen!

    Whatever those "gibberish files" are they are radioactive.

    In any effect, I've got a new harddrive coming in the mail this week....been meaning to upgrade to a 2 tb anyway.

    Weird wild stuff.
     

Share This Page