Finder Crashes when Opening One Specific Folder?

Discussion in 'PowerPC Macs' started by tommytune, Oct 2, 2012.

  1. tommytune, Oct 2, 2012
    Last edited: Oct 2, 2012

    tommytune macrumors newbie

    May 12, 2011
    Desperately seeking Help!

    Trouble started when my Downloads folder (in my Documents folder) began to crashe the finder every time I do ANY of the following:
    • double click it to open
    • single click to get info
    • navigate to it in a finder window in EITHER column view or list view

    I can't do any activity regarding this folder without it crashing the finder. I was able to (one time only) copy the files in the downloads folder to a new folder. I guessed from reading other threads, that the DS_store file was the problem.
    But the new folder with the files from the original crashes the finder in the same manner !!??:confused:

    I've used the terminal to delete the DS_Store file from the original folder as well as the newly created folder.

    I've managed to use a backup utility to copy the folder to another admin user acct where I can access it just fine.

    But any attempt to access it from my account results in a finder crash.

    After the first crash, clicking ANY item in the sidebar also crashes the finder. The crashing issue seems to "propagate" from that "problem folder". After the first crash, some folders on the desktop work fine, other's now also crash the finder.
    Deleting finder plists seems to revert the system to crashing only on that folder, but once the finder crashes, other finder operations also cause a crash.

    I'm copy pasting the first few lines of the crash report and the lines referring to the crashed thread (I can post more of the logs if needed).

    I've already trashed the finder prefs and the dock prefs (I've been researching this issue for days, now) with no joy. Same result.

    Since it WAS the only folder that caused the finder to crash, I had assumed it's something to do with that specific folder...
    But being able to access it AND it's items (1,700 files, large and small) from another account now makes me doubt this.

    Other than the pref files I deleted, I don't know what else regarding the finder I can try.
    I'm totally stumped.

    the log excerpts are below.

    My system PowerMac G5 10.4.11
    log excerpt:
    Host Name: xxxx-Computer
    Date/Time: 2012-10-02 19:10:42.351 -0400
    OS Version: 10.4.11 (Build 8S165)
    Report Version: 4

    Command: Finder
    Path: /System/Library/CoreServices/
    Parent: WindowServer [3274]

    Version: 10.4.7 (10.4.7)
    Build Version: 1
    Project Name: Finder_FE
    Source Version: 5292900

    PID: 4169
    Thread: 5

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0x850d53f4
    Thread 5 Crashed:
    0 ...ple.CoreServices.CarbonCore 0x90b9e138 CSStoreGetUnit + 56
    1 0x91944074 _LSBundleFindWithNode + 204
    2 0x91943250 _LSFindOrRegisterBundleNode + 112
    3 0x9194fae8 _LSCopyItemAttributeForRefInfo + 164
    4 0x92b0d9b0 LockLSCopyItemAttributeForRefInfo(LSExtendedFSRefInfo const*, unsigned long, __CFString const*, void const**) + 76
    5 0x92b0d6e4 THFSPlusRef::GetDistinctDisplayName(unsigned long, FSCatalogInfo*, HFSUniStr255&) const + 144
    6 0x92b0d60c THFSPlusRef::SetDisplayName(unsigned long, FSCatalogInfo&) + 64
    7 0x92b0c998 THFSPlusRef::Set(bool, FSRef const&, HFSUniStr255 const*, short, unsigned long, bool, unsigned long, FSCatalogInfo*) + 920
    8 0x92b14088 THFSPlusIterator::Next(THFSPlusRef&) + 300
    9 0x92b13f18 THFSPlusSynchronizer::Next(THFSPlusStore&) + 32
    10 0x92b13d74 THFSPlusStore::CreateChildren(TChildrenList&, TNodeTask*) + 148
    11 0x92b13c60 TNode::CreateChildren(TNode::StSynchronize const&, TNodeTask*) + 112
    12 0x92b13838 TNodeOpenSyncTask::OpenSyncTaskProc(void*) + 204
    13 ...ple.CoreServices.CarbonCore 0x90bc665c PrivateMPEntryPoint + 76
    14 libSystem.B.dylib 0x9002b908 _pthread_body + 96

    Thread 5 crashed with PPC Thread State 64:
    srr0: 0x0000000090b9e138 srr1: 0x100000000200f030 vrsave: 0x0000000000000000
    cr: 0x24008482 xer: 0x0000000000000000 lr: 0x0000000090b9e110 ctr: 0x0000000090b9e100
    r0: 0x0000000000000000 r1: 0x00000000f0301810 r2: 0x00000000050b8000 r3: 0x000000000112af00
    r4: 0x000000000000019c r5: 0x000000008001d3f8 r6: 0x0000000000000000 r7: 0x00000000eeeeeee1
    r8: 0x0000000000000ff7 r9: 0x0000000000000000 r10: 0x0000000000000ec4 r11: 0x00000000a193c5f0
    r12: 0x0000000090b9e100 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
    r16: 0x0000000000000000 r17: 0x0000000000000000 r18: 0x0000000000000000 r19: 0x0000000000000000
    r20: 0x0000000000000000 r21: 0x00000000f03019d8 r22: 0x00000000f03019d4 r23: 0x00000000f03019d0
    r24: 0x00000000f0302ea8 r25: 0x00000000f0301a70 r26: 0x0000000000000000 r27: 0x0000000000000000
    r28: 0x000000000180ce00 r29: 0x00000000a193dab8 r30: 0x00000000850d53f8 r31: 0x0000000090b9e110
  2. justperry, Oct 3, 2012
    Last edited: Oct 3, 2012

    justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    If you login into a guest account or as root is the Finder also crashing when you open the folder?

    If not it is something in your user account which has a conflict.
    What you could do if this is the case is to rename or put the preference folder somewhere else in your User account and log out an in again, if still does the same do it with the library folder.

    Move-Or rename
    User/***/Library/Preferences For instance rename to preferences1

    Move-Or rename
    User/***/Library For instance rename to Library1

    Better login into root to do this, just give it a try

    If this helps you have to move step by step to find out the conflict.
    So, if one of the above resolved the problem you could for instance move half the preferences to a new folder and look what happens, if still there it's in those pref. files if not move them back(give them a color within finder) and move half of the other half out and so on until you find the problem file.
    Same goes for the Library folder

    You can always go back into root and remove the newly created Library and Preferences folder and put back the old one or rename, dependable on what you did.
  3. orphanartist macrumors newbie

    Oct 6, 2012
    I just had the same problem, and your reference to DS_Store gave me a clue that solved it for me.

    You can probably do this in a less GUI way, but I opened Onyx, and under the "Maintenance" tab, then "rebuild", there's an option to rebuild the display of folders' content.

    I chose the folder that enclosed the problem folder, checked the "apply to sub-folders" option, and ran it. If you don't do it via sub-folders, you'll crash Onyx when the problem folder is selected.

    This deletes the DS_Store file in enclosing folders, and solved issue for me.

    Hope this helps.
  4. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    The Terminal is the fastest and cheapest way to delete that file, no need to download anything.
    But since you started there is also a program called Easyfind, you click where you want to search, so you point towards that folder and it shows up, press delete, done.

    Didn't help for the OP though, might have solved it since we didn't hear from him.
  5. tommytune thread starter macrumors newbie

    May 12, 2011
    Still here, still having issues. Next Step???

    It's me.

    I couldn't replyto you good folks because I couldn't logon to rumors, or anywhere. I'm a musician (=moron) and I save and enter all my passwords 'electronically', so I couldn't even remember how to logon to my email to retrieve any of my forgotten passwords. And the account started looping crashes so I couldn't even open my "every password I ever used" document/database.
    It didn't occur to me that I wouldn't have access from my other account. I've only used it once or twice. Finally I 'forced my way in' (see below) and got the passwords.

    So far, I renamed the user preferences folder and moved it. It 'rebuilt' itself, minus a million entries. This system has been upgraded numerous times & the install disk will no longer work (I need OS 9 for some music programs and ADATs).

    Doing that allowed me to login with the 'problem account', however, after clicking the Documents folder in the sidebar once, the finder crashed again.

    Then, simply clicking the User/Documents folder crashes the finder. And the looping crashes began again.

    This was AFTER I 'deleted' the entire preferences folder for the account.
    My 'testuser' account seems to be ok.

    I created a superuser account, since I couldn't access one admin account from the other.
    Reading about root user accounts appears to indicate the only way to have read/write priv's for all accounts is to do this.

    Unfortunately, before I learned about root, I was able (can't remember how), to allow writing to the desktop folder on the problem account, and I'm going to have to revert the access settings, since I've also read that changing system-y settings can be very bad in itself, right?
    I'm totally gonna need someone to talk me through fixing that!

    At this point anyway, I'm trying to figure out if it's the second possibility mentioned: the User/Library folder. I know pref files recreate themselves, but how do I 'test-delete' the library folder?? Won't that cause mayhem?

    What's the exact procedure?
    So far, since the looping crashes continue, seems obvious it can't be the prefs (or at least not the prefs alone)

    Also, I deleted just the 'desktop' and 'downloads' folder DS files, nothing recursive yet, since this worries me.
    What happens if I delete all the DS-Store files as suggested?
    Will I lose all settings for the folders that I do this to? i.e. folder colors, icon positions on the screen etc.?

    I need a clear (non-geek version) set of terminal commands.
    I have to do it from the terminal, since I can't even login to the damaged user account.

    Finally which should I do first? The user/Library thing or the DS file thing?
  6. tommytune thread starter macrumors newbie

    May 12, 2011
    Something else? Moved Prefs & User Library... No change

    So here's what I did.

    1. Renamed the baduser/prefs folder - restarted, prefs folder rebuilt itself result. result- No meaningful change. 'Finder cycling' stopped but finder quits at any instance of clicking a sidebar item, or attempt to open Documents folder.

    2. I Left the 'new' rebuilt prefs in place & Renamed baduser/Library Folder, restarted & let that Library folder rebuild. Result- finder wasn't 'cycling' but quit at any instance of clicking on the sidebar.

    3. I used Grab to take a pic of the Folder... Users/baduser in column view, showing all the remaining folders in the user account. I'm amazed that's apparently not either the prefs or the Library folder.
    If I Log out of baduser, login to testuser, there are no finder quits at all. Finder Operates normally. huh?

    So it must be something else in the baduser Home Folder that's at least contributing to this.

    I'm at a loss, probably missing something obvious.

    Attached is the window grab from baduser/, as viewed from 'testuser'. The Library Folder seen in the grab is the 'new rebuilt' folder.

    (for some reason, you'll have to click on the small pic below to view it in a reasonable size)

    Attached Files:

  7. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    So, still not solved, this is a hard one, I never came upon a conflict like this which wasn't solved by removing/renaming Preference/Library Folder.

    The only thing I can think about now is to remove or delete Caches in /Library and/or /System/Library/Caches.

    About removing all the .DS_store files, you probably loose all the settings if you go ahead.
  8. ovje macrumors newbie

    May 19, 2013
    Partial and temporary solution:

    I have exactly the same problem and nothing here said solved it. I opened my Aplications Folder and chose the problematic one inside it and pressed cmd+i to get the item info window, then I changed permissions and ownership to my user and pressed to apply to enclosed folders........ it responded well once, I could open it, then it started failing again...?!
  9. David Skaïa macrumors newbie

    Aug 30, 2015
    Solved it
    I deleted all files in the download folder with Onyx. Select Maintenance then reconstruct. Could access the download folder with the "file content" then and took to the trash folders one by one all the files. The crash occurred it seems when a half dowloaded file was interrupted.
  10. seenz macrumors newbie


    Nov 17, 2016
    I had this same issue with my Downloads folder, and deleting the .DS_Store folder in terminal fixed it.

    In case anyone needs it, this is what worked for me:

    Open "terminal" application, then type these two commands: "cd downloads", "rm -rf .DS_Store" and it will delete that folder. Problem solved. If the problem folder is somewhere else, you have to navigate to that host folder first. If you don't know what you're doing, don't risk it.

Share This Page