Finder crashes with Bus Error when removing language support from apps

Discussion in 'macOS' started by yeroen, Mar 7, 2008.

  1. yeroen macrumors 6502a

    yeroen

    Joined:
    Mar 8, 2007
    Location:
    Cambridge, MA
    #1
    How to crash Finder:

    Open the /Applications folder in Finder
    Select an app, :apple:-i click to bring up the info dialog
    In the Languages scroll-list, unselect all unwanted languages.
    Close the info dialog box.
    Finder crashes with a Bus Error (you can open console.app to see the log report)

    Finder doesn't crash if you remove one language at a time (until you get to the last non-English one..or of course if you simply delete or move these language support files to the "Resources\ Disabled/" folder in terminal).

    Does anyone else see this?

    (and no, before anyone responds, it has nothing to do with permissions)
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    doesnt happen to me when i move all of VLC's languages to the trash except English and close the get info window.
     
  3. yeroen thread starter macrumors 6502a

    yeroen

    Joined:
    Mar 8, 2007
    Location:
    Cambridge, MA
    #3
    It just crashed for me when I moved VLC's foreign language resource files to the Trash (vs just disabling them).

    A finder crash won't be obvious (i.e. no pop up dialogs). If you read the console.app message window while doing this, or afterwards in terminal:

    ls -ltr ~/Library/Logs/CrashReporter

    do you see any Finder<date><computer name>.crash files?

    Also, what OS/platform are you running? I'm on 10.5.2, 2006-model Mac Pro.
     
  4. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #4
    i did EXACTLY wat you just did haha

    moved VLC languages other than English to the trash then closed the Get Info window on a 2006 Core Duo MacBook Pro running 10.5.2 and no crash! :D

    try deleting Finder's plist (youll have to redo all your settings in Finder's preferences)
     

Share This Page