finder crashing and now mac running slowly and behind

Discussion in 'Mac Basics and Help' started by Richdj, May 17, 2010.

  1. Richdj macrumors member

    Joined:
    Jan 24, 2008
    #1
    Hey everyone,

    Just got my new I7 mac about 2 weeks ago, everything was fine until the last few days, and are slowly getting worse.

    Ive always had a few finder crashes, but in the last day its a constant thing, Ive launced the mac with no apps running, and clicked finder, everything seems fine until I click on the applications folder, it starts loading then crashes, then relaunches and crashes and so on, eventually it populates the window but then if i click into any folders it crashes again. All other folders, ie my user folder etc seem fine.

    Ive read lots of forums on this problem and went ahead and deleted the apple.com.plist file, this has not helped.

    Ive also tried repair permissions and have a few weird thing on there which Ive attached a grab of below. which i dont understand.

    Anyway, since all this, all of a sudden when im in the middle of working my mac starts lagging, the expose seems to crash and then all my keystokes are really behind even when i try and click on the apple to force quit or to try and get out of anything the menus take ages to pop up once ive clicked on them .... its driving me mad......

    The only strange things ive done recently are as follows, i dont know if this has any bearing on my problems.

    Basically at the weekend I was trying to burn files to a DVD disk, i kept getting an error, which when i searched online suggested that delete the apple.com.plist file and that would solve it.
    It seemed to work the next disk i burned , burned without error after wasting about 10 DVDs before this.

    The next thing is that i set up a virgin online back up account which back up my files off site, this is normally running in the background, however at present ive quitted this programme to see it it helps..

    Finally yesterday ive had problems with my accounts programme and needed to run it on another computer to redo the files, i couldnt download a copy of the programme so i connected my mac to my friends mac and transferred the programme file over.
    After doing this i had problems running my programme but when i searched online for the error it said i didnt have prmissions on the application folder, so i had to right click the folder and change it so that i could read and write to the folder.

    These are the only things ive done which is different to my normal work jobs.

    Please can some one help me figure out what is wrong and why my repair disk wont complete.
     

    Attached Files:

  2. forcefieldkid macrumors 6502

    Joined:
    Jan 20, 2010
    #2
    I think you should backup your data re-install to be honest.
     
  3. Richdj thread starter macrumors member

    Joined:
    Jan 24, 2008
    #3
    reinstall osx?
     

Share This Page