Finder Crashing?

ntdogg511

macrumors newbie
Original poster
Mar 4, 2008
17
0
Anyone else having an issue with Finder crashing forever in a loop? I can also get it to crash if I click through folders in the sidebar.

Not sure if it's a bug or I'm the only one experiencing this. I've tried deleting the Finder pref plist as well as the sidebar plist.

See anything I might be missing here? Other than Finder crashing all the time I'm impressed with how stable it is and how many applications actually work right out of the gate on a DP1 beta.
 

bc2116

macrumors newbie
Jun 6, 2011
4
0
me too

Yup, finder is crashing like rough surf for me too... Nothing more to contribute, but just so you don't feel lonely.

Anyone else having an issue with Finder crashing forever in a loop? I can also get it to crash if I click through folders in the sidebar.

Not sure if it's a bug or I'm the only one experiencing this. I've tried deleting the Finder pref plist as well as the sidebar plist.

See anything I might be missing here? Other than Finder crashing all the time I'm impressed with how stable it is and how many applications actually work right out of the gate on a DP1 beta.
 

ntdogg511

macrumors newbie
Original poster
Mar 4, 2008
17
0
Thanks Mate, guess surfs up!

IN the meantime I have written an ode to this innovation called tabbed finder and my time with it so far.

Oh Finder I would like to open my Downloa..... NO

Finder, why did you do that, I just wanted to see the file I download..... NO

Are you mad finder? I'm sorry I made you try to copy that 2TB file to my... NO

If I open a new tab will it.... NO

Why do you let me see all my applications? I just want to see my google drive...NO


But Finder...NO

Find.... NO

NO NO NO NO NO NO NO NO NO NO NO NO NO NO NO NO NO NO NO NO


Would you like to not reopen me when I crash?

YES
 

w0lf

macrumors 65816
Feb 16, 2013
1,233
73
USA
Are you maybe running any apps that are trying to interface with Finder? I've only had it crash once when I tried to run XtraFinder, hasn't crashed since.
 

maflynn

Moderator
Staff member
May 3, 2009
65,032
30,956
Boston
Do you have gotomypc installed? This it seems causes an endless loop of Finder crashes.

Kill the app and that should fix it.
 

stijnbakk

macrumors newbie
Oct 27, 2013
1
0
I seem to have fixed it. I think totalfinder caused the problems, I fixed it by starting up terminal and use:

sudo rm -rf /Applications/Totalfinder.app

After a quick reboot the problem did no longer occur. Maybe you can use this trick with other apps that cause similar problems?

Good luck!
 

BobbyDigital

macrumors member
Sep 13, 2006
96
0
Google Drive was making my Finder crash. I quit Drive, crashing stopped. As soon as I started Google Drive again, endless crashing loop about once every 30 seconds.

I also run Dropbox, but there's no problem with that. Hopefully Google gets it sorted out soon.
 

w0lf

macrumors 65816
Feb 16, 2013
1,233
73
USA
Google Drive was making my Finder crash. I quit Drive, crashing stopped. As soon as I started Google Drive again, endless crashing loop about once every 30 seconds.

I also run Dropbox, but there's no problem with that. Hopefully Google gets it sorted out soon.
Think it might be a specific issue with you. I run Google Drive no problem, maybe try wiping the prefs for Google Drive and reinstalling the app.
 

josh256

macrumors newbie
Nov 4, 2013
5
0
Google Drive definitely crashing Finder on my Mac

Removed Google Drive and all is well..

Code:
11/4/13 10:28:08.346 PM Google Drive[316]: Failed to send: -609
11/4/13 10:28:08.448 PM ReportCrash[6255]: Saved crash report for Finder[6244] version 10.9 (10.9) to /Volumes/Vette/Users/Joshua/Library/Logs/DiagnosticReports/Finder_2013-11-04-222808_MacPro.crash
11/4/13 10:28:08.451 PM ReportCrash[6255]: Removing excessive log: file:///Volumes/Vette/Users/Joshua/Library/Logs/DiagnosticReports/Finder_2013-11-04-220756_MacPro.crash
11/4/13 10:28:08.622 PM Finder[6256]: copyPrimaryAirPortInterface::ACInterfaceDeviceNameCopy returned NULL
11/4/13 10:28:21.710 PM login[6261]: USER_PROCESS: 6261 ttys000
11/4/13 10:28:25.308 PM com.apple.launchd.peruser.502[197]: (com.apple.Finder[6256]) Exited: Terminated: 15
11/4/13 10:29:08.862 PM com.apple.launchd.peruser.502[197]: (com.apple.Finder[6266]) Job appears to have crashed: Segmentation fault: 11
11/4/13 10:29:08.938 PM Google Drive[316]: Failed to send: -609
11/4/13 10:29:09.028 PM ReportCrash[6279]: Saved crash report for Finder[6266] version 10.9 (10.9) to /Volumes/Vette/Users/Joshua/Library/Logs/DiagnosticReports/Finder_2013-11-04-222909_MacPro.crash
11/4/13 10:29:09.046 PM ReportCrash[6279]: Removing excessive log: file:///Volumes/Vette/Users/Joshua/Library/Logs/DiagnosticReports/Finder_2013-11-04-220856_MacPro.crash
11/4/13 10:29:09.230 PM Finder[6280]: copyPrimaryAirPortInterface::ACInterfaceDeviceNameCopy returned NULL
11/4/13 10:29:11.275 PM sandboxd[368]: ([6269]) mdworker(6269) deny file-read-xattr /Volumes/Evora/360/Call of Duty Ghosts 2 (pre-plugin fstype:hfs fsflag:4A09018 flags:240000005E diag:0 isXCode:0 uti:public.iso-image plugin:internalPlainTextImporter - find suspect file using: sudo mdutil -t 1759)
11/4/13 10:29:18.782 PM login[6261]: DEAD_PROCESS: 6261 ttys000
11/4/13 10:30:09.403 PM com.apple.launchd.peruser.502[197]: (com.apple.Finder[6280]) Job appears to have crashed: Segmentation fault: 11
11/4/13 10:30:09.527 PM Google Drive[316]: Failed to send: -609
11/4/13 10:30:09.568 PM ReportCrash[6290]: Saved crash report for Finder[6280] version 10.9 (10.9) to /Volumes/Vette/Users/Joshua/Library/Logs/DiagnosticReports/Finder_2013-11-04-223009_MacPro.crash
11/4/13 10:30:09.586 PM ReportCrash[6290]: Removing excessive log: file:///Volumes/Vette/Users/Joshua/Library/Logs/DiagnosticReports/Finder_2013-11-04-220957_MacPro.crash
 

BobbyDigital

macrumors member
Sep 13, 2006
96
0
A temporary fix for the Google Drive issue

Just a follow-up... found a temporary fix for the Google Drive issue here:

https://discussions.apple.com/message/23669582#23669582

Just disable the option for "show file sync icons" in Google Drive's preferences.

Seems like Google pushed an update to Drive yesterday that caused this. A bit frustrating, as it took me a good 2+ hours to pinpoint what was causing the issue.

Hope this helps!
 

hallux

macrumors 68030
Apr 25, 2012
2,777
485
For everyone saying Google is to blame, the Google Drive app had not changed version numbers between Oct 26 this year and last night when this started happening. Unless they pushed an update with no version number change (poor work if they did), IT'S NOT GOOGLE'S FAULT.

By the way, Google has already fixed whatever was broken (either by them or by Apple). Less than 24 hour turn-around isn't bad.

https://productforums.google.com/forum/#!msg/drive/kqdqmoMWtk8/0iuozNmuSb8J
 

guzforster

macrumors newbie
Dec 7, 2011
3
0
Mine was Copy app. Before, it was Google Drive that was making this happen. I uninstalled it and installed it again and the problem went away. But then it started again after some days - and this time it was the Copy app, which has the same purpose as Google Drive or Dropbox. Something tells me that some update from Apple was made to the OS and theses kind of apps didn't follow.

This time I didn't need to uninstall Copy, just closing it solved the issue...
 

juanomatic

macrumors newbie
Jan 6, 2010
11
1
New York City
This kept happening to me when I migrated to a new rMBP on Yosemite 10.10.2. (Feel free to move to that forum if it's more appropriate).

The app that caused the Finder crash was Transporter Desktop (filetransporter.com). Currently trying to reinstall to get it to work again.
 

d.c. Golden

macrumors newbie
Sep 4, 2016
1
0
A temporary fix for the Google Drive issue

Just a follow-up... found a temporary fix for the Google Drive issue here:

https://discussions.apple.com/message/23669582#23669582

Just disable the option for "show file sync icons" in Google Drive's preferences.

Seems like Google pushed an update to Drive yesterday that caused this. A bit frustrating, as it took me a good 2+ hours to pinpoint what was causing the issue.

Hope this helps!
[doublepost=1473026084][/doublepost]This solution worked for me. When I disabled "show file sync icons" in Google Drive it solved the issue. Thanks for saving a lot of trouble for me :) Mine was a macbook Air with OSX 10.9.5.