finder freezes during copy "some data could not be read or written"

Discussion in 'macOS' started by natechien, Jan 14, 2009.

  1. natechien macrumors newbie

    Joined:
    Jan 14, 2009
    #1
    Hi everyone :)

    I am running osx 10.5.4 on a brand new macbook.

    I have an old, crappy external hard drive that works intermittently with a bunch of large files on it that I am copying to my new, fancy external hard drive. Problem is, more than half the time, finder will report "unable to complete the operation because some data on 'filename' could not be read or written. (Error Code -36)"

    This would be no problem, as I could then just cancel the copy and try again. But Finder freezes the copy window open, and it will not close by clicking on the "x" in the copy window. The only way to try again is to relaunch Finder. I do not want to force finder to quit every time I try to copy a file to my new drive. Is relaunching finder repeatedly bad for my system or hardware? Seems like a glitch. Is there a way around this?

    This guy also had the same problem, but it was a one-time thing:
    http://forums.macrumors.com/showthread.php?t=535453

    thanks,

    natechien
     
  2. jive turkey macrumors 6502

    Joined:
    Mar 15, 2008
    #2
    Crazy, I had a very similar problem last night, but I didn't get an error code. I was trying to transfer a series of videos to an external HD and Finder would transfer a few MB's then freeze, and like you I couldn't do anything except force quit. I tried it 5 times, which was no doubt foolish, but since it froze at a different MB size each time I though I would keep giving it a shot.

    Eventually my desktop went totally blank except for my mouse pointer and wallpaper. No menubar, no dock, no app windows. I couldn't force quit from the keyboard either, so I finally had to hold the start button down and manually kill the machine (something I HATE to do). I restarted it and attempted the transfer again, and it worked perfectly. I've been about 26 hours now and everything is working fine.

    Long story short, have you restarted you computer? :p It fixed my problem.
     
  3. natechien thread starter macrumors newbie

    Joined:
    Jan 14, 2009
    #3
    yeah i've restarted a bunch of times... its more of a tendency. Its not debilitating to my machine, its just a pain. I can't copy more than one file at a time, and larger files usually crap out at least once before they work. The weird thing is really that after the transfer doesn't work, the copy window won't close.
     
  4. lukaz99 macrumors newbie

    Joined:
    Mar 31, 2009
    #4
    external HD freezing

    i am having the same problem and its spreading to my other external hard drives. ive tried a ton of things to try and fix it but nothing seems to work.
    can any one help?
     
  5. McMark macrumors newbie

    Joined:
    May 3, 2005
    Location:
    Australia
    #5
    possible solution

    I have read your threads this morning after experiencing same.
    The finder froze while trying to copy a zip file to my ext hard drive.
    This has happened before on my macbook, so I unarchived the zip and placed the app into a folder and it copied no problem. This is after many restarts
    and permissions repairs and using the onyx utility . I hope this helps
     
  6. mac2ubuntu macrumors newbie

    Joined:
    Dec 20, 2009
    #6
    Finder crashes when any problem copying is a recurrent Mac problem!

    This is a bug of the Mac OS X from the beginning -- complete gracelessness of the copying function in the Finder. You often can't stop copies, even though there's a little button that supposedly does it. You click it and often nothing happens. And if there's any hiccup -- any problem with the media, any corrupt file -- then very likely the whole system will freeze.

    That's my experience over multiple systems and flavors of OS X.

    Copying files is a basic function of the Finder -- and Apple has left this festering sore for years. Ignoring fundamental OS issues while pouring on ever more GUI glitz isn't what users want.

    I hear 10.6 improves a lot of basic functions -- I hope this is one of them.
     
  7. kgeier82 macrumors 65816

    Joined:
    Feb 18, 2008
    #7
    I am trying to back up 1.5GB of movies onto a second HD, and have actually had to abandon doing it in OSX. Doing it on my MBP in windows.
     
  8. brian9271 macrumors 6502

    brian9271

    Joined:
    Jan 31, 2008
    Location:
    Next door
    #8
    Man this is soooo hard to back up my stuff, Time machine won't backup my stuff anymore, it keeps failing, I've tried with 2 different external hard drives but no luck, so I decided to put everything in one file - 32 GB and drag it over to both hard drives but keeps getting the same error as you guys, really annoying, so now I can't back up no matter what ARGGHHH! :mad: Even if I restart my Mac it won't work, only a few files get transfered thats all :confused:
     
  9. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #9
    Onyx really helps things out if you have been running a long time and things are slow and all that.

    I had a similar problem involving one particular CD I was trying to rip. No other CD caused the same issue, and said CD worked fine in the iMac running SL.
     
  10. chipperson macrumors newbie

    Joined:
    Jun 27, 2010
    #10
    Possible Due to FAT32 on Destination Drive

    you may be running into trouble if you're copying files that are too large for the destination drive- if it's formatted to work for both Mac and PC, it's likely to be formatted as FAT32, which has a 4GB per file limit (i've seen somethings about the lit actually being 2GB).
     
  11. Philalbe macrumors 6502

    Joined:
    Jun 11, 2010
    Location:
    Greater Boston Area
    #11
    That happens to me a lot when trying to transfer data from old CDs or DVDs. Finder will freeze and refuse to close. I just open up the force quit window and click on Finder. It will ask if you wish to restart finder and I click yes. It quickly restarts Finder without disturbing any other programs that happen to be running. I know when that happens to me with old discs, it's usually because the disc is beat up. Not sure why it would happen with a external drive, unless some of the data got corrupted? Strange.
     
  12. chipperson macrumors newbie

    Joined:
    Jun 27, 2010
    #12
    Solution!

    I just came across the solution below, and it worked perfectly for me.

    http://www.macyourself.com/2010/01/07/solution-to-finder-error-code-36-in-10-6-when-copying-folders/

    in a nutshell:
    1.) open terminal from the applications >utilities >Termanal

    2.) type in "dot_clean" (no quotes, and make sure there's a space after "dot_clean")

    3.) Find the folder that's giving you trouble and drag it into the terminal window (the file location should pop in right after the"dot_clean" you typed in)

    4.) Hit enter

    it won't seem like anything happened, other than the creation of a new line in the terminal window, but your trouble file should no longer be giving you issues :D
     
  13. davidnssbm macrumors regular

    Joined:
    Oct 23, 2009
    #13
    this did not work for me. any other solutions?
     
  14. merman637 macrumors member

    Joined:
    Jan 21, 2002
    Location:
    Oklahoma City, Ok
    #14
    solution please

    also did not work for me...
    i can move the file on the same hard drive, but cannot copy.
    I have tried repair, dot_clean, opens fine in itunes but cannot copy from itunes (had to try)
    I am lost.
     
  15. skajam66 macrumors newbie

    Joined:
    Jan 26, 2011
    #15
    I've just started getting this error. I'm running 10.6.6 and backing up to an external 1TB drive. It has been working fine for over a year now, suddenly, I start getting this Error 36 problem. THe solution from the guy who fixed it via dot_clean does not work for me since this fix applies to 10.6.2 or earlier (it was fixed in 10.6.3).

    The biggest problem is that it destroys your data on the target drive when it fails so be careful!

    Anyone got a solution?
     
  16. djchriscleary macrumors newbie

    Joined:
    Mar 8, 2011
    #16
    Hi,

    I am new to mac, but have been having the same issues, I have been trying to copy my windows data over to my mac and getting the same ERROR 36 message,

    I have just spoken to mac and they have said that there is no definitive solution yet but there is a way around it.......

    Apple said because of the fact that my drive is in NTFS or FAT32 this is the reason the files will not carry over. The temporary solution is to.....

    1. Back up all your files that you want to transfer onto the windows machine (or another external harddrive)
    2. Replug the external harddrive into the mac machine.
    3. On the mac, Open Applications > Utilities > Disk Utilities
    4. Highlight the external harddrive > Accross the top there should be tabs for first aid / erase / partition etc....
    5. Click the "Erase" Tab> In the format box chose "MS-DOS (FAT)" option
    6. Format the drive in this format.
    7. Reconnect the drive in the windows machine > transfer the files you want to copy on to it
    8. Your drive should work at copying data from there...........

    I hope this helps, (if this is obvious, please dont laugh at my amatuer mac skills :))
     
  17. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #17
    You posted this same thing in another thread, and it's just as wrong here. It is NOT necessary or recommended to reformat the drive to FAT32 to solve this issue. FAT32 has a file size limit of 4GB, which is unacceptable for many users. You can resolve this problem using the steps in the following link:

    Solution to Finder “Error code -36″ in 10.6 when copying folders
     
  18. djchriscleary macrumors newbie

    Joined:
    Mar 8, 2011
    #18
    Dude this does not solve the problem, i have tried it a hundred times and IT DOESNT WORK! Either does any other solution posted in this thread or any previous threads i have been reading, So i called apple and explained my situation they gave me these steps, i followed them and it worked for me, so i'm sorry for taking up 8 lines of your thread, but i thought i would just post it just incase anyone was having a similar problem, if the solution is not specific to peoples needs, they can dismiss it, in future I will not post, sorry again.....
     
  19. mdutoit macrumors newbie

    Joined:
    Sep 28, 2009
    #19
    Hi GGJstudios

    I have a different but similar problem.. I have a NTFS external drive (being written to via Tuxera-NTFS plug-in), and have a few files that I simply can't delete (getting the infamous error -36 code). It's just a few files in folder with other files that can be deleted, so it's not folder related.

    I tried your post regarding dot_clean with these individual files, dragging them individually into my Terminal windows, but then i get an error stating "Bad path/Not a directory" etc. As a test I then dragged the whole folder (which contain the mixture of good and bad files) into the terminal and dot_clean executed happily without any feedback of problems. But the problem persists - i still can't delete those particular fies.

    Do you have any other suggestions? I'm running the latest Snow Leopard at the time of this posting.

    Regards
     
  20. aoitsukinosuke macrumors regular

    Joined:
    Jun 13, 2011
    #20
    I know it's been a while since someone last posted on this thread. But, I wanted to write my solution, if it can be regarded as one, so that people might benefit in the future.

    I'm running on a Leopard and occasionally had the same problem for a while. Mainly, it was when I was copying multiple large sized files, over 800mb or so, from an external hd to my Mac Mini.

    To eliminate the freeze, I now copy files one at a time. Never had the error message or freeze since.
    When the freeze happened the last time with multiple copying, my solution was simple.
    I click the Activity Monitor, force quit finder and start my copying from scratch.

    Not a solution all together, but at least a fix when you get stuck.
    Hope this helps.
     
  21. mdutoit macrumors newbie

    Joined:
    Sep 28, 2009
    #21
    Thanks for you input.
     
  22. IsraelThompson macrumors newbie

    Joined:
    May 23, 2013
    #22
    Solved

    Ok, everyone, I know this thread is pretty old, but I created an account here just to lend a hand for anyone else that stumbles in and is left with no solution... just as I was:

    First, let's round up as many of the solutions being offered out there that will probably NOT work for you IF you are in the same boat as me.

    1. Close down everything and reboot your machine (Seems easy enough, but too good to be true!)
    2. Try copying files one at a time (Too much work! No WAY)
    3. Repair disk permissions
    4. Using Terminal's "cp" and "rsync" to transfer files (as opposed to Finder)
    5. Use the "dot_clean" method (Apple’s 10.6.3 update back in '10 reportedly fixed this anyways? And we're way past that, right?)
    6. Format as MS-DOS (FAT)... Really? Seriously? Wipe all my files? NO THANKS!

    In all of these —*well, besides 2 and 6 which I decided were just completely ridiculous and out of the question —*the problem for me was not solved in the slightest. BUT, I did figure out what was ailing me!

    The problem had nothing to do with the disk, permissions, or the operating system. No bugs. No viruses. No cyber conspiracies. Nope... Just a simple tiny minuscule hardware issue.

    **drumroll, please**

    For me... the external drive I was trying to copy files from, was plugged in via a USB hub. After removing the hub from the picture, the problem vanished like a whore on a Church day! So the solution.. and I know this seems too good to be true, but try by:

    1. Checking your cabling. How are your drives connected? Internal/External? Does the problem happen only when external drives are presented? Or with internal-to-internal?
    2. Try plugging in all your external devices directly to your USB ports instead of any hubs.
    3. Make sure your cables themselves are up to par.
    4. If you have to, try testing with different cables.

    Hope this helps.
     

Share This Page