Finder Go menu > Go to Folder: Forward slash deleted

Discussion in 'macOS Sierra (10.12)' started by Signum17, May 14, 2017.

  1. Signum17, May 14, 2017
    Last edited: May 14, 2017

    Signum17 macrumors newbie

    Joined:
    Jun 11, 2013
    #1
    Ok, here is something I cannot figure out. I type forward slash "/" in the Go to Folder field and it simply backspace deletes it. I have to paste my path in.

    Example: /Library/ becomes /Library before I can continue.

    I can type the first forward slash, second one vanishes.

    I can "cheat" it by typing two slashes and deleting the first one: /Users//Gene for example.

    I try another account, same thing.

    What is going on?

    MBP 2012/OSX10.12.4

    Gene
     
  2. Watabou, May 14, 2017
    Last edited: Jul 11, 2017

    Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #2
    I've noticed it too and it's been bothering me as well, but I forgot to report that bug to Apple.

    I think it must be a bug, otherwise I don't see any reason why it should be deleting the trailing slash.

    Anyway, I just posted the bug report on bugreport.apple.com.

    They usually reply to me for non duplicated bugs, so I guess we'll see what happens. Hopefully they fix that behavior. I don't see a way around it, unfortunately.
     
  3. Signum17 thread starter macrumors newbie

    Joined:
    Jun 11, 2013
    #3
    Thanks!! There are times I wonder if it's just on my end. Glad I checked in.

    The workaround is to paste the path in or type two slashes and delete the first.

    Once the path has been typed, it's usually stored in the recent paths.

    No fun,but will do for now.


    I'm also having UDMA crc errors with my SSD. I'll either have to reseat the drive or replace the drive cable. I've got all the tools and parts on order, but for a second I thought it was related.

    Appreciate it,

    Gene
     
  4. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #4
    It gets deleted after a second or more here, you have all the time to write whatever you have to write.
     
  5. Watabou, May 15, 2017
    Last edited: May 15, 2017

    Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #5
    For me, it keeps deleting it every half a second, so sometimes, as I'm starting to type more, it deletes it, and is just plain annoying behavior. There's no reason why it should delete it anyway.

    EDIT: Apple just replied to my bug report saying they need a screen recording. I guess it's good that they didn't flag it as a duplicate, which means no one else reported this issue.
     
  6. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #6
    While I can duplicate what you're seeing with the release version of 10.12.5, you're typing more than you need to.
    If you use tab completion to fill in your path, the slash will stay there and you'll type many fewer characters.
    For instance, type /Lib<tab> and the field will fill with /Library/.
     
  7. Signum17 thread starter macrumors newbie

    Joined:
    Jun 11, 2013
    #7
    Ok, it works. While I don't think the disappearing slash is normal, the Tab complete method is a good shortcut.
     
  8. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #8
    This issue is now fixed in High Sierra beta 3

    Looks like Apple did read my bug report :)
     

Share This Page