Finder "Go To" and ~Library

Discussion in 'OS X Mavericks (10.9)' started by chekz0414, May 17, 2014.

  1. chekz0414 macrumors 6502a

    chekz0414

    Joined:
    Jul 3, 2011
    Location:
    FL
    #1
    Ever since the betas of 10.9.3 I have been unable to access the ~Library on OS X, where iTunes stores .ipsw for iOS devices... Has anyone found a solution to restore it back to how it was on older versions of Mavericks? *Below is an attachment of what I mean*

    EDIT: The folder DOES exist still, Finder just won't go to it.
     

    Attached Files:

  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    It works fine for me, but I didn't include the 2nd slash. I doubt it would make a difference, but I just used ~/Library

    Are you current with all updates, including iTunes?
     
  3. chekz0414 thread starter macrumors 6502a

    chekz0414

    Joined:
    Jul 3, 2011
    Location:
    FL
    #3
    Yup I am on the current iTunes, and I just tried without the second slash as ~/Library, and it still has the same "Folder cannot be found" text. :(
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Try re-indexing your drive: If that fails to index, enter the following command in Terminal:
    sudo mdutil -i on "/Volumes/your drive name"​
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    Does it work if you use the menu bar? Hold Option and select Go > Library.
     
  6. mojolicious macrumors 68000

    mojolicious

    Joined:
    Mar 18, 2014
    Location:
    Sarf London
    #6
    Surely 'go to folder' isn't dependent upon the target being Spotlight indexed?
     
  7. chekz0414 thread starter macrumors 6502a

    chekz0414

    Joined:
    Jul 3, 2011
    Location:
    FL
    #7
    Hmm neither are making Spotlight re-index? Terminal told me indexing enabled...and the folder still cannot be accessed from "Go To" the only workaround I found is holding down the option key and going to the "Go" menu in Finder makes the folder show there and from there as long as I hold option down I can click the folder to open... .__.

    ----------

    I've confirmed this method works, but the "Go To" does NOT, for some reason
     
  8. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #8
    Once you're in there, right-click on the folder icon in the title bar and confirm that it is indeed in the correct place (Users > yourname > Library). I can't imagine that it wouldn't be, but it's worth checking.

    Also, what happens if you simply enter "~" into the Go to Folder window?

    Edit: I'd also be interested in seeing the output of "echo ~" from Terminal.
     
  9. chekz0414 thread starter macrumors 6502a

    chekz0414

    Joined:
    Jul 3, 2011
    Location:
    FL
    #9
    So, I think it is in the right place *see attachment* BUT the other things you told me to try going to have the same "cannot be found"
     

    Attached Files:

  10. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #10
    Please post the exact output of the Terminal command; I can't think of any reason for a "not found" message since it shouldn't be trying to parse the directory.
     
  11. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #11
    I notice in your screenshot ~/Library is greyed out. Normally this means the folder is hidden, although that should still not block access like you are seeing.

    [​IMG]

    Here is the same shot on mine and notice it is not greyed out.

    I'm wondering if you have some odd hidden/permissions issue lingering from the betas?

    Try this... enter the command below in Terminal to unhide the ~/Library folder.

    Code:
    chflags nohidden ~/Library/
    Then let's reset your user folder permissions to default. Do a command-r boot to recovery then start Terminal from the Utilities menu and enter "resetpassword" (all one word without the quotes). That will bring up this screen.

    [​IMG]

    Select Macintosh HD at the top the select your use account in the drop down just below that. Leave all three of the password fields blank as we don't want to change that. Now click the Reset button at the lower right to set your user folder back to default permissions. Then go ahead and quit that screen.

    While still in recovery start Disk Utility and do a permissions repair and a repair disk both. (I doubt these last two things are related to your issue, but it does not hurt to do it while in recovery for good measure.)

    Now reboot and see if that fixed it.
     
  12. bobdamnit macrumors regular

    Joined:
    Mar 26, 2014
    #12
    I've had the same problem before. I fixed it by making sure that "Show Library Folder" was checked in Finder preferences. This will also disable the "greyed" Library folder that was shown in your screenshot and make it look like this:
    [​IMG]

    To do this, go to your username home folder and then select View>View Options in the Finder Menu.

    Then make sure its checked like the following:
    [​IMG]
     
  13. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #13
    That should fix the greyed folder issue, but I think OP has something else going on. Even with that unchecked and the Folder hidden, you can still get to the ~/Library folder with the Go to... menu, and OP can't seem to get that to work.
     
  14. bobdamnit macrumors regular

    Joined:
    Mar 26, 2014
    #14
    Ahh. It appears as though you are correct. I just unchecked "Show Library Folder" and used "Go to Folder" in the Finder menu and it indeed took me to ~/Library.

    I swear I remember this not working in 10.9 until I checked "Show Library Folder", but I could be mistaken.
     
  15. chekz0414 thread starter macrumors 6502a

    chekz0414

    Joined:
    Jul 3, 2011
    Location:
    FL
    #15


    THANK YOU SO SO MUCH. THIS FIXED IT. My folder also isn't grayed now!! :p
     

Share This Page