Finder hangs at startup


macrumors 65816
Original poster
Nov 25, 2004
Korova Milkbar
Everything ran smoothly for the... ohhh 4-5 years I've had Mac OS X. Then, one day a couple of weeks ago [using 10.3.7], my internet magically "shuts down" while my computer is on [this is the only pretext to my finder problem]. Nothing I could do could restart the internet: power cycling the modem/router, creating new connection settings, whatever. So then, I decided to restart. This is when my Finder hung at startup. Soooo, I let it sit there for a while [if you try to force relaunch the finder too early, the system will reboot, otherwise, the finder will relaunch back again into "spinning beachball death" but the startup items will finish loading] and after about 5 min of not touching anything [not trying to relaunch Finder] it will startup. However, if the Finder hangs [for me] at startup, the internet will not work at all. Soooo crap.

So I went through my basic troubleshooting scheme, rebooting from a CD and running the likes of DiskWarrior, TechTool4 and DiskUtility. The first time I did this, everything went back to normal. However, after another 12 hours of the computer being on, the internet mysteriously cut out again, so I knew the Finder would hang if I rebooted [which it did]. So I did what I had done before but this time nothing worked. Soooo I tried a combo power-cycling modem/router-while-booted-from-cd-and-running-repairs thing and it worked. So I went along my merry way and it happened again. This time after about 24 hours.

So then I boot up from my Panther disk to run repairs from there. This time, I only have my modem unplugged [in all/any way it can be unplugged] and upon restart it worked fine. Good. Great. Dandy.

Then after another unknown amount of hours [2 days or so] it happens again. Sigh.....

"OK, screw this", I thought. I'll just reinstall and everything will be OK. So I boot from my Panther disk, zero my boot drive and reformat to Journaling ["Fine, if Mac OS X would rather have journaling then it might make my life easier"]. I reinstall only the BSD Subsystem as an option so I only have to use 1 disk. Then I go about re-customizing my OS to my liking, adding this time only LittleSnitch, MenuMeters and TransperantDock [as opposed to all the crap I had on before, with around 10 "other" system preference panes and a "full" Applications folder]. Then after another 48 hours the system craps out. Just long enough after I had everything to my liking.


So I go about reinstalling again, this time from a friends Panther disk, just to make sure. Instead of zeroing the drive again, I just erase and reinstall. Upon the very first restart, the Finder hung........ "Dear Mac Gods......"

So the next time, I try zeroing AND "8-way random write" to my drive just to make sure everything is nice and clear before I start again. Oh, by the way, did you know it takes around 13 hours to 8-way random write to a 30gb hard drive? Anyway, this time I get it started after and immediately [as I usually do] run permission repair and then update my OS. Then after reboot, I repair permissions again and proceed to get more updates. Oh, and at this time I had been recieving weird permission problems such as:

User differs on ., should be 0, owner is 501
Permissions differ on ., should be drwxrwxr-t , they are drwxrwxr-x
Owner and group corrected on .
Permissions corrected on .


Permissions differ on ./private/etc/slpsa.conf, should be -rwxr-xr-x , they are -rw-r--r--
Owner and group corrected on ./private/etc/slpsa.conf
Permissions corrected on ./private/etc/slpsa.conf

I repair my permissions regularly and have never seen either of those before.

Let's see.... where was I.... oh, 3rd reinstall I think.

Ok, so I continue to update my system [this install was when 10.3.8 came out, before the full combo update] and get it to 10.3.8. I happily chug along thinking 10.3.8 was a god send, and go forth and install LittleSnitch and MenuMeters [two things I can't live without] directly from the developer sites. Then the problem happens AGAIN after another 24 hours or so of no restart after installing LS.

So now I'm really angry. I search Apple's boards and google the problem to find that it's happened to more than a few people. They have suggestions such as to reset pram, delete user and system caches and delete certain user/system preferences. "How could I have a corrupt cache or pref on a fresh install?", I think. So I reboot and let the system hang until it finally boots up [but with no internet access] and I enable invisible items and proceed to trash all my caches [only this so far]. Since some are still in use, I have to reboot to empty the trash. So I do so. The Finder hangs the next start up, but I figure that's just a warmup for the files I just deleted. So I restart again. Finder still hangs. Luckily I had to leave at this point, so I keep my system running, getting ready to reinstall again for the 4th time when I return.

8 hours later I get back with the system still on, and I proceed to try out the internet. It works [and the Finder hung at the last startup], so I figure the cache files was a good thing to delete, but was weary that my intrernet had "mysteriously" worked without much effort and the Finder still hung. Sooo I go about my business trying to forget all that happened, but still knowing in the back of my mind that it could just as eassily happen again. Which it does. Soooo just last night, before I decide to reinstall Panther again, I emptied out my logs/caches again just to try and get the internet working for any brief amount of time. Upon restart, the Finder worked but the Dock didn't load. This is a new one for me, and any attempts to restart or open the dock were futile.

I reinstall Panther again with OnyX ready and proceed to do the following immediatly after each reboot/OS update:

Repaired permissions, completely redid optimization [prebinding], ran all [daily, weekly, monthly] cron scripts, and deleted all logs, user cache, system cache, .DS files, files, temp files, and virtual memory files.Then for reassurance I enabled invisible items and manually deleted all prefs and caches in my user and system libraries, and then to top it off, reset my PRAM on each restart.

I do this religiously 3 times. One after initial install, again after the first update [iTunes, iCal and all that, along with the 10.3.8 Combo from a 10.3 install = 102mb btw], and once more after the next update which included Java, QT, and those two lonely 2004 Security Updates that are for particular apple apps and not necessarily the system [I think iCal and iChat, why they don't include them in updated versions of the apps is beyond me] which do not appear unless you have those apps installed [which I didn't initially].

Now I'm at my 4th install running on a system with only a few of my more essential third party apps = FireFox, BBEdit, OnyX, MPlayer and VLC and no third party system apps [littlesnitch, menumeters]. Oh, and by the way, I had at least [at most with menumeters] LittleSnitch installed on each previous installation, excluding the time the Finder hung after the first restart of a fresh 10.3.. that time I didn't even have enough time to say, "Hello new system!", let alone install something.

So here I am after giving my OS one hell of an enema hoping that everything will be OK lest I be forced to smash my system into tiny little bits, put it in a mulcher, then try to kill the larger bits in a garbage disposal, only to set aflame the flakes of former greatness to make sure that nothing survives :)

That or I could try another harddrive.... however this doesn't seem like a hardware failure to me. Just a serious of unfortunate events =\ That saying, as I'm the only person [that I know of] to have the Finder hanging at startup in conjunction with the internet problem.


Edit: And I did check my Firmware updates just in case [Sawtooth firmware and third party PCI controller for a 160gb drive] I also have a GigaDesigns 1.4ghz upgrade card installed with a Radeon 8500 and 832mb RAM [512, 128, 128, 64] which I have had no problems with in the at least 2 years I've had all of these upgrades. Nothing ever fresh or new was installed which immediatly lead to the problem. It only ever happened after so many hours [again, excluding the one time it happened after a fresh install] of the system being on.

if you've made it this far, thank you!


macrumors 604
Jan 20, 2005
I'm having the same problems of Finder stalling on fresh reboots after installing 10.3.8. I believe there is something seriously wrong with 10.3.8 Update. I am in the process now of doing a complete re-install of 10.3.4 that came with my G5. I will not be updating to 10.3.8 until we get an acknowledgement from Apple regarding this.

Although on my PB, 10.3.8 seems to be running fine. Oh well, seems x.8 updates seems to screw up each release.


macrumors G5
Jun 6, 2003
Solon, OH
I'm getting Finder stalls too...although they only last for 5-15 seconds, and only after a cold boot or restart. I didn't get these before 10.3.8 either.


macrumors 604
Jan 20, 2005
Well, I did a complete format of the hard drive, re-installed 10.3.4 and then updated to 10.3.8. Re-installed all my programs and settings from scratch, and now my computer runs like a cat. Finder boots up instantaneously now. Everything all good.


macrumors 6502
Dec 1, 2003
About 2 or 3 weeks ago, the internet in my dorm cut off during the day. I hadnt noticed until I went to restart my computer (I had just installed an app or something, dont really remember) for a normal reboot. Right away. my finder started hanging. It would hang for about 30 seconds to a minute. After it finally launched it was fine, but then Mail started to hang too. So I started askign around, and found that a lot of other people around me weren't getting internet. I kept restarting, repaired permissions, checked processes, and just tried to trouble shoot for a while. After about an hour, the internet came back, and everything was fine. I guess the settings I had going, like - several widgets with konfabulator needing a net connection, mail auto checking for mail and then every minute after launch, syngery needa net connection, and probably some other stuff I cant think of right now - were affecting my start-up sequence. Obviously it seems like your problem is much deeper than what I experienced. But your internet/finder hang problem caught my eye, so I figured I would let you in on my experience. I hope maybe something I said will be of some use to you. Good luck!


macrumors 68000
Jan 6, 2004
Cape Cod
The Finder always hangs on me when I have a lot of icons on the desktop.... maybe ~16 or so.

edit: I'm currently using 10.3.8, but this has happened to me for any version of 10.3.x
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.