Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Finder - In Column View Can't sort by Date Created

tijiay

macrumors newbie
Original poster
Jan 10, 2014
4
0
I had a failing HD, which I just replaced in Dec. 2012, with a solid state drive. I also upgraded my OS to 10.9.1 at the same time.

I don't know if that's caused the changes in Finder, but it no longer works the way it used to.

Selecting Column View, it used to list all of the files in a folder, and I could sort all of the files by Name, Date Created, Date Modified and so on. That worked great.

But now it groups older files by year (and not accurately), and only sorts on the most recent files (say the last 30 days).

Which makes this useless to me.

Below is an example of how the files in a folder are grouped.

I would love to be able to get rid of this grouping approach, and go back to being able to manipulate, and order, all of the files in a folder by the same approach (Name, Date, Modified, etc.)

Any ideas about what I can do to fix this? (If I use "List View" there is no problem sorting by Date).

Also any idea why it groups files in the wrong years?

Thanks for any help. Tom



Here's how the files in one Folder are grouped. I've clicked on Sort by Date Created, and this is what it does:

______________________
Today

[2 files, sorted by date]
______________________
Previous 7 days

[4 files, sorted by date]
______________________
Previous 30 days

[3 files, sorted by date]
______________________
2011

[mysteriously, files created in 2012 are grouped here under 2011, and sorted in Alphanumeric order - there is no grouping for files in 2013 or 2012]
______________________
2010

[files created in 2011 are grouped here, sorted in Alphanumeric order]
 

wmthrone

macrumors newbie
Jan 13, 2014
1
0
Similar problem

I'm relatively new to mac - no failing HD on my MBPro w/ retina. But now in Finder when I select to "Arrange By" the "Date Modified" in column view it shows all the files that should be labeled 2013 as 2012. I didn't even have the computer then and none of these files existed in 2012.
Using OSX - 10.9.1.
Would love to find a fix for this.
Thanks!
 
Comment

tijiay

macrumors newbie
Original poster
Jan 10, 2014
4
0
A partial fix for Sorting by Date Created

I haven't solved the problem completely, yet, but there's a quick fix that helps a lot.

In View, click on Show View Options and change the preference for "Sort by:" to "Date Created".

This solves my immediate problem (being able to toggle between the "arrange" options, and when I choose "date created", having all of the files in the folder sorted by "date created", rather than just grouped by year, and then arranged alphabetically).

I'll find out if it causes problems when I need to sort some other way...

Arranging by "Date Created", Finder is also now grouping files by year correctly. Don't know how that got fixed, but glad it is.

Tom
 
Comment

minche

macrumors newbie
Feb 12, 2014
1
0
I don't know if this will help, but I usually sort by Date Modified, and was wondering why Finder no longer sorted the most recent files at the top within the "Previous 30 days" category. I clicked on the gear button for the folder I was in, "Show View Options", and chose "Arrange by: Date Modified" and "Sort by: Date Modified", and it is sorting as I want it to now.

So maybe try to "arrange" and "sort" by "Date Created" to see if works as you want it too.
 
Comment

dylin

macrumors 6502a
Jun 10, 2010
647
49
California
I haven't solved the problem completely, yet, but there's a quick fix that helps a lot.

In View, click on Show View Options and change the preference for "Sort by:" to "Date Created".

This solves my immediate problem (being able to toggle between the "arrange" options, and when I choose "date created", having all of the files in the folder sorted by "date created", rather than just grouped by year, and then arranged alphabetically).

I'll find out if it causes problems when I need to sort some other way...

Arranging by "Date Created", Finder is also now grouping files by year correctly. Don't know how that got fixed, but glad it is.

Tom

Just to help out with what Minche said
 

Attachments

  • Image001.jpg
    Image001.jpg
    157.5 KB · Views: 968
Comment

newperfectionist

macrumors newbie
Dec 1, 2015
2
0
Same problem with El Capitan (10.11.1)
Unbelievable. This worked nicely until OSX 10.6. and now, upon searching for files in Finder, there is always one and the same option of search criterion: "Date added". No chance to change it to "Date modified". The next bug is that the date is always in the American style. There is no adaption of the date style in accordance with the adjustment of the system preferences.
 
Comment

nytexano

macrumors newbie
Jan 31, 2016
2
0
New York
A partial fix for Sorting by Date Created

I haven't solved the problem completely, yet, but there's a quick fix that helps a lot.

In View, click on Show View Options and change the preference for "Sort by:" to "Date Created".

This solves my immediate problem (being able to toggle between the "arrange" options, and when I choose "date created", having all of the files in the folder sorted by "date created", rather than just grouped by year, and then arranged alphabetically).

I'll find out if it causes problems when I need to sort some other way...

Arranging by "Date Created", Finder is also now grouping files by year correctly. Don't know how that got fixed, but glad it is.

Tom
It's the little things that count: I doubt I would have thought of selecting the 'Sort By' option under View Options. Instantly, my arrange by Date Added worked again. How it was deselected I leave as a mystery. Thanks much.
 
Comment

newperfectionist

macrumors newbie
Dec 1, 2015
2
0
nytexano, thank you for your comment.
In the meantime I found a solution. I am not sure as to whether this is due to the update to 10.11.3 or whether I have overseen so far:
Right click on one of the sort criteria (for instance ""yesterday" if it appears as criterion), then a pop-up menu is shown by means of which one can choose/change the respective criterion.
Voila.
Even the date format is then the correct one, which, btw is not true in Apple Mail 9.2, provided that the preference layout is not the classical one. Then always the American style of the date format is displayed.
 
Comment

nytexano

macrumors newbie
Jan 31, 2016
2
0
New York
nytexano, thank you for your comment.
In the meantime I found a solution. I am not sure as to whether this is due to the update to 10.11.3 or whether I have overseen so far:
Right click on one of the sort criteria (for instance ""yesterday" if it appears as criterion), then a pop-up menu is shown by means of which one can choose/change the respective criterion.
Voila.
Even the date format is then the correct one, which, btw is not true in Apple Mail 9.2, provided that the preference layout is not the classical one. Then always the American style of the date format is displayed.
[doublepost=1454949978][/doublepost]New perfectionist,

After my 3rd conversation with a 2nd Senior Advisor at Apple I was able to make progress. Via screen share he was able to witness the witless new Window disorder. Either arbitrary order, or, in Name View, backwards order. This happened in Column View AND List View. I always rely on Column View, changing arrangement according to need. There's never been even a thought about this–until now.

What the advisor was able to discover was that in VIEW - SHOW VIEW OPTIONS, 'Sort By' must remain by 'Name'. 'Arrange By' varies according to what you select using right click or the 'Arrange By' Panel within a window. With 'Sort By: Name' providing the base, you can Arrange By any of the available criterion without getting a jumbled incoherent order.

Hope this was helpful.
 
Comment

Matthias Bauer

macrumors newbie
Sep 16, 2015
2
1
[doublepost=1454949978][/doublepost]New perfectionist,

... in VIEW - SHOW VIEW OPTIONS, 'Sort By' must remain by 'Name'. 'Arrange By' varies according to what you select using right click or the 'Arrange By' Panel within a window. With 'Sort By: Name' providing the base, you can Arrange By any of the available criterion without getting a jumbled incoherent order.

Its July 2017 (Sierra) and I still have the same problem. I found 5 ways to influence the sorting in finders column view:
  1. Action icon at the top of the finder window / Arrange By / <Name|Kind|...|None>
  2. Arrange Icon at the top of the finder window / <Name|Kind|...|None>
  3. View menu at the top of the desktop / <Name|Kind|...|None>
  4. View menu at the top of the desktop / Show View Options / Arrange By in the popup window / <Name|Kind|...|None>
  5. View menu at the top of the desktop / Show View Options / Sort By in the popup window / <Name|Kind|...|None>
1. to 4. are synchronized, i.e. if e.g. Date Modified was chosen by one of the ways 1. to 4. then Date Modified is active in all other places 1. to 4.. Also the settings 1. to 4. all are change synchronously by the shortcuts shift-command-N (By Name) and shift-command-M (By Date Modified). Only the setting 5. is not scynchronized. It can only be changed in the cumbersome way as described nytexano or 5. im my list above. To get reasonable sorting it should be choosen the same as the settings 1. to 4. I think it is cumbersome and I think this was not intended by the programmers.

@Apple: please tell your finder programmers to repair this bug!
Many thanks
 
  • Like
Reactions: ___Jayse___
Comment

___Jayse___

macrumors newbie
Jul 15, 2019
1
0
July 2019 - still broken.

But kind of a fix: hold down option to see sort options rather than Arrange only.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.