Finder issue copying large files from a bus powered USB external

Discussion in 'macOS' started by mgclayton, Jun 18, 2008.

  1. mgclayton macrumors member

    Joined:
    Dec 19, 2007
    #1
    I think I have found a bug in Finder where I cannot copy large files from a bus powered USB external. I get this error:
    "The Finder cannot complete the operation because some data in "..." could not be read or written (Error code -36)"

    I think I have eliminated hardware as an issue:
    1. The problem is repeatable (and always happens) on my Intel Macbook Pro, Intel Mac Mini and G4 Mac Mini
    2. The problem happens whether I have formatted the external as HFS+ or NTFS (I can't use FAT32 for files over 4GB, e.g. VMWare disk images)
    3. I can copy the files off the external with my Windows Vista machine (mostly dormant these days) and an XP laptop (I use for work), using Explorer.
    4. The same problem happens with two different external enclosures (An Xtatix Portadrive and a Beyond Micro mobile Disk). I have also tried 3 different 2.5" drives in these enclosures.
    5. If I boot my Macbook Pro into Vista using Bootcamp, I CAN successfully copy the files using Explorer.
    6. I CAN also copy the files OK if I use Terminal and the 'cp' command (it works for all 3 machines)
    7. I have NO problems with large files and Finder if I use a powered external with 3.5" drives via USB or Firewire (HFS+ or NTFS) on any of the Macs.

    As you see, I think I've been pretty thorough. It seems as though Finder must be at fault when used with a bus powered USB external.
    I should also mention that all 3 of my Macs are on Leopard 10.5.3, though I did also boot a my Intel Mac Mini into Tiger with the same result (Finder failed, 'cp' worked).

    I have reported the problem to Apple, but wondered if anyone else has had a similar issue...and hey, a solution would be a great bonus! :)
     
  2. TheDudeAgain macrumors newbie

    Joined:
    Nov 10, 2008
    #2
    same same...

    I've got the same issue here. G5 8core 3.2, OS 10.5.5, 4T internal, 7T external. error occurs (if I get one) when transferring large files and large numbers of files. As I type, my finder is completely blank, locked in a relaunch.
    : (
    Your description was definitely thorough and accurate. it's repeatable here too. This started in the last 4-5 months (hey, finder came back). I originally thought is was the DVD data format I was getting from a vendor, but since then, It happens with files/folders that I generated. Currently trying to copy 150G of 26 video files from an external to an internal - the defining word there is 'trying'.

    You're not alone, but where we are kinda sucks.

    : )
     
  3. theLimit macrumors 6502a

    theLimit

    Joined:
    Jan 30, 2007
    Location:
    up tha holler, acrost tha crick
    #3
    I've had problems like this for years on my Macs, and was told by a genius that the USB bus on my PowerBook was didn't have enough power for the 100GB external drive I was using. I started using a USB-to-power cable and an iPod USB power adapter and it works fine. I've upgraded machines and still have the problem on bus power.
     

Share This Page