Finder keeps stealing focus, hiding all windows (then unhiding)

mixvio

macrumors 6502
Original poster
Apr 12, 2009
388
0
Sydney, Australia
This is a bit of a bizarre bug and searching on google I can't find anything at all (saturated results about Finder in general.)

Since upgrading to ML I've noticed that the Finder keeps stealing focus and rapidly hiding/unhiding all windows when it does. I'm not yet certain what triggers it, though I believe that it's related to launching a new program (but I can't get it to happen 100% of the time). Finder pulls focus from whatever application I'm using and hides everything for a second before unhiding it — it's like the applications all blink out, and when the system is booted up it happens quickly but at times (like just after start up when I'm launching a bunch of programs) the hidden windows don't get restored for long enough that I was able to figure out why everything was suddenly disappearing.

Am I the only one getting bothered with this? I can't seem to figure out why it's doing it.

* ETA: I figured out a solution, see below.
 
Last edited:

jollypants

macrumors newbie
Aug 8, 2012
1
0
losing focus

yeah, I am having this experience as well when working in outlook.
no fix yet.
 

mixvio

macrumors 6502
Original poster
Apr 12, 2009
388
0
Sydney, Australia
Messing around with it further I have isolated it down to every time I open a new program — every other application hides and Finder takes the foreground. I thought it might be happening at other points, but it's actually just when I launch a new application.
 

JacaByte

macrumors 6502
Dec 26, 2009
315
0
Restarting has fixed a great deal of computer problems since the 1980s. Just as good a suggestion then as it is now.
 

mixvio

macrumors 6502
Original poster
Apr 12, 2009
388
0
Sydney, Australia
Okay after messing around further I believe the issue is related to the wonderful Stay application. Unchecking the option to restore windows at application launch (at least, might also be good to uncheck the one about restoring windows at resolution change too) seems to stop the issue. I finally realised that the flickering through windows and applications hiding/unhiding looked really close to what Stay does on normal operation (and it matches the fact that it was only happening to me when I launched a program) so once I shut that option off it stopped happening.

I've sent the developer a quick email so they know about the issue, I guess it hasn't been updated fully for Mountain Lion yet.