Finder not showing external disks on desktop, even when I have it selected in preferences

Discussion in 'Mac Basics and Help' started by Sossity, Jul 6, 2016.

  1. Sossity, Jul 6, 2016
    Last edited: Jul 6, 2016

    Sossity macrumors 6502a

    Joined:
    May 12, 2010
    #1
    It was working fine yesterday, I changed my desktop background, and today, all of a sudden, external disks do not show up on the desktop, even though I have it selected in finder preferences, I see it in the side bar, but not desktop. The main internal drive shows up but not my Seagate portable external.

    I tried going in and deleting preference files in the library and restarting, this did not work.

    The drive shows in the finder sidebar fine, but not desktop,

    also, firewire connected drives show up fine on the desktop.

    and I also tried plugging in a usb thumb drive, it showed, so it seems I have isolated the problem to the Seagate hard drive

    I am running mavericks 10.9.5. on a mid 2010 classic mac pro.
     
  2. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
  3. Sossity thread starter macrumors 6502a

    Joined:
    May 12, 2010
  4. Sossity thread starter macrumors 6502a

    Joined:
    May 12, 2010
    #4
    I also noticed something else odd, I just tried plugging in another external hard drive into my mac pro, and the same thing; it shows in finder, disk utility, but not desktop, despite that I selected for external discs to show in finder preferences.

    What both these hard drives have in common was I had plugged them into my mid 2014 retina macbook pro running el capitan, it seems it has altered the drives somehow, because now they do not show on my mac desktop, but they did before I had plugged them into my macbook pro.
     
  5. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #5
    Could your finder prefs file be corrupted?

    Try this:
    - Go to your "preferences" folder inside your home folder
    - Locate the file "com.apple.finder.plist" and move it to the trash, but
    - DO NOT empty the trash yet.
    - Now, reboot
    - When you get to the finder, empty the trash
    - Now open finder preferences and re-do your settings.

    The above routine will force the creation of a "fresh" finder prefs file, which you can then re-adjust to your liking.

    Does this change anything?
     
  6. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #6
    In other words, the same as suggested in the post above? If not, what did you delete?
     
  7. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #7
    Is there any possibility that the drive is showing up in a different space? Try switching spaces to see if that is the case. (Do a four finger swipe to left or right.)
     
  8. Sossity thread starter macrumors 6502a

    Joined:
    May 12, 2010
    #8
    ok all, thanks, I figured it out, when I have multiple things open, like web pages finder, etc, it covers things I have on my desktop, among them was this drive, because my macs main internal drive always seems to show up in the top right corner of my screen, I expected the other hard drive to as well, it was not, it was showing in or practically in the middle of my desktop, so I have not bee seeing it mounting.

    For some reason, as I mount and eject hard disks, they start to get scattered on my desktop, instead of staying in order along the right side of my desktop, how I like them to. Is there a way to keep them lining up to the right side of the desktop?
     
  9. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #9
    That should be the default. Try dumping your Desktop plist file (then Restart) and see if that solves it.
     

Share This Page