Finder quits and does not launch

Discussion in 'Mac OS X Lion (10.7)' started by minws13, Feb 11, 2012.

  1. minws13 macrumors newbie

    Joined:
    Dec 4, 2011
    #1
    Hello everyone,

    I'm having a weird problem in Lion.

    I can quit Finder with command + Q (!) but then it does not launch. Only with the command in terminal
    sudo /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder

    which does not fix the problem, I only get empty windows and cannot access my hard drive.

    Performed a permissions repair and verified disk, but nothing gets fixed.
    Any ideas?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    To relaunch Finder, rather than Quit, use Command-Option-Escape then select Finder and click Relaunch. Or hold the Option key and right-click on the Finder icon on the Dock to select Relaunch.
     
  3. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #3
    Have you got some weird Login Item, daemon, or Service that responds to cmd Q in Finder? Finder has no 'Quit' menu item, so the key combo is being interpreted elsewhere.
    You also might check Keyboard Shortcuts Prefs pane for an unwanted cmd Q interpretation.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    :)
    ScreenCap 37.PNG
     
  5. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #5
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    To add a "Quit Finder" entry to the Finder menu, type the following in Terminal:
    defaults write com.apple.finder QuitMenuItem -bool yes
    killall Finder​
    Or use the Secrets preference pane:
    ScreenCap 39.PNG
     
  7. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #7
    You might try from terminal: killall "Finder" to get it restarted. [this might fail if you've already quit Finder, but is worth a shot]

    Or make an Applescript based Automator service to which you can add a kybd shortcut:
    Code:
    do shell script "killall Finder"
     
  8. minws13 thread starter macrumors newbie

    Joined:
    Dec 4, 2011
    #8
    For some reason it got fixed.

    I had the option "Add quit item to Finder menu" checked, but unckecking didn't do the trick...

    "killall Finder" wasn't working as well...

    I dunno, I restarted a couple of times an since then its working fine.

    I hope I dont get back to having the same problem.

    Thanks alot for the help people!
     

Share This Page