Finder relaunch loop + all apps crash on startup

Discussion in 'OS X Yosemite (10.10)' started by sfilipe2, Jul 27, 2016.

  1. sfilipe2, Jul 27, 2016
    Last edited: Jul 27, 2016

    sfilipe2 macrumors newbie

    Joined:
    Jul 27, 2016
    #1
    Hi everyone, hope y'all can help me.

    So, last night when I turned my Macbook Pro Retina off I did notice something weird, it said some preferences .plist file couldn't be found or something along those lines and I had to force quit everything

    Today when I went to turn it on, as soon as I log in the finder keeps on crashing with the "Last time you opened Finder it quit unexpectedly" box, and relaunching and crashing again in a fraction of a second. All the apps that I have opening on startup also crash. Sometimes all the items I have on the desktop will flash and dissappear. Also if I try to launch any app (minus gadgets like the calculator) it will crash right away with the "X quit unexpectedly.

    Now, I've tried a lot of stuff to try and delete the finder .plist file which is what is probably causing this, but when I boot in safe mode it freezes on the Yosemite blurred wallpaper, nothing happens.

    I can't use finder at all to delete it from there.

    What else can I do? The terminal that I can run from Recovery mode is a bash shell so it can't help.

    And if that wasn't enough I only have 3gb left so I can't reinstall Yosemite.

    Please help! Thank you in advance
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    In Recovery Mode, go to disk utility, then click on MacIntosh HD and run First Aid (or Repair Disk) depending on which version you have.
     
  3. sfilipe2 thread starter macrumors newbie

    Joined:
    Jul 27, 2016
    #3
    I've done that sir, thank you. I've also tried Repair disk permissions, everything was fine.
     
  4. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #4
  5. sfilipe2 thread starter macrumors newbie

    Joined:
    Jul 27, 2016
    #5
    Unfortunately I don't.

    Would a bootable usb with Yosemite be able to repair/reinstall the OS without needing the 12gbs?

    Other than that I'm only really seeing the alternative of going to a Genius store and ask them to do what you suggested. I'm 99% sure it's the com.apple.finder.plist file that is corrupt.
     
  6. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #6
    If you have an external USB drive, you could boot from the recovery partition, reformat the external as Apple Extended Format (Journalled) with a GUID partition map, then install Yosemite on the external from the recovery partition.

    Then reboot holding down the option key to boot from the external. You can then access the internal HD using Finder and delete whatever files you need to delete.
     
  7. sfilipe2, Jul 28, 2016
    Last edited: Jul 28, 2016

    sfilipe2 thread starter macrumors newbie

    Joined:
    Jul 27, 2016
    #7
    I still haven't been able to try that, but I noticed right now that some times there are two instances of Finder running in Force Quit, one always open and the other keeps relaunching and crashing on its own. And now, I tried doing a Repair Disk and it says something in /System/Library/CoreServices is corrupt and can't be repaired...



    This is what everything looks like
     

    Attached Files:

  8. sfilipe2 thread starter macrumors newbie

    Joined:
    Jul 27, 2016
    #9
    So I just tried everything, installed Yosemite on an external, deleted all the finder.plist, also tried that last suggestion, and it's still not working. Weird that when I go back there still isn't another finder.plist created.

    I'll just try reinstalling Yosemite on the main drive. I'm just happy I could back up everything!
     

Share This Page