Finder showing multiple shared devices..

Discussion in 'OS X Yosemite (10.10)' started by Martin29, Oct 12, 2014.

  1. Martin29 macrumors 6502

    Martin29

    Joined:
    Nov 25, 2010
    Location:
    Quimper, France
    #1
    I am running the latest public beta version of 10.10.

    My finder sidebar is currently showing multiple versions of my shared Macbook Air i.e.. Air; Air(1); Air(2)..Air (12)

    I only have one shared Air and this is a new issue.

    Is anyone else experiencing this? If so do you have a solution?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I did see some posts with others having the same problem, but I don't recall anybody finding a solution. Looks like a bug.
     
  3. rokko101 macrumors newbie

    rokko101

    Joined:
    Oct 12, 2014
    #3
    Hi there.

    I had the same issue with my Mac Mini using 2 Airport express base stations.

    My solution: Cycle power your base stations... that was an instant solution to my problem.

    Let me know if it works.

    Bye.
     
  4. MCSN macrumors regular

    MCSN

    Joined:
    Feb 7, 2012
    Location:
    Kayenta
    #4
    same issue

    I'm having the same issue with iMac and shared devices.

    i posted a recent thread, since I hadn't seen this one in a search until after posting. I wasn't sure how to write a question for this. But yah, same issue.

    Someone said something about NAT, will I mess everything up if I turn off the NAT?
     
  5. lpb macrumors newbie

    Joined:
    Jul 26, 2013
    Location:
    Sweden
    #5

    Attached Files:

  6. smoroz macrumors newbie

    Joined:
    Oct 13, 2014
    #6
    Sleep & AppleTV or Synology

    It appears to be a combination of 2 things. Firstly it is when the Yosemite machine wakes from sleep and thinks there is another machine with the same IP address on the network. The machine name gets changed, adding (1) (2) etc.

    Then it appears that another box on the network, in my case it was an AppleTV, has cached those names. Rebooting the AppleTV got rid of all the duplicates.

    I have heard that perhaps removing any static IP addressing on a router may resolve the sleep issue, but I have not tried that yet myself. Now that I have gotten rid of all the duplicates I will see if the problem comes back.

    I have also heard that Synology boxes cause the same problem by cacheing the names.

    Stacy
     
  7. 3282868 macrumors 603

    Joined:
    Jan 8, 2009
    #7
    Interesting. I have two Synology servers on my network running two new Airport Extreme Base Stations (one in bridge mode). Regarding Static IP's, it is essential to assign servers and desktop systems with a constant static IP, especially if you access your systems via VPN or BTMM. I stopped assigning static IP's to mobile devices a long time ago as it's easier for the router to address the issue (no pun intended). ;)
     
  8. R3k macrumors 6502a

    Joined:
    Sep 7, 2011
    Location:
    Sep 7, 2011
    #8
    I'm also having this issue, not with multiple shared versions of a computer appearing on the sidebar, but with my computer name changing all the time:

    Computer
    Computer (2)
    Computer (4)

    etc.

    I bring my computer home from work, open the lid, and it thinks there is another computer with the same name on the network, and it renames itself to compensate.

    en1 duplicate IP address 10.0.1.3 sent from address XX:XX:XX:XX:XX:XX

    Started happening with Yosemite, 2009 MBP on an Airport Time Capsule with pretty standard settings.

    The reason this is a pain is that my iPhone will be set to sync over Wifi with my laptop, but it will not work because its looking for "Computer" instead of "Computer (2)"

    Grr
     
  9. rmcnelly macrumors regular

    Joined:
    Jul 23, 2011
    Location:
    Portsmouth, VA
    #9
    I rebooted my Airport Time Capsule and it solved the problem. I think it fixed my problem with handoff as well.
     
  10. surroundfan macrumors 6502

    Joined:
    Nov 22, 2005
    Location:
    Melbourne, Australia
    #10
    I had this issue too with my rMBP .

    It looks to be an issue with DHCP because I was also unable to set a static address, my router was not recognising the MAC address of the rMBP's wireless and assigning another IP and I was getting lots of 'Another device is using the address ....' error messages when I tried setting the static IP address manually in the Mac.

    I nuked the /Library/Preferences/SystemConfiguration folder and rebooted. Since then, no more problems, with only one instance of my rMBP in shared devices list and I can set a static IP...
     
  11. Frits48 macrumors newbie

    Joined:
    Aug 10, 2014
    #11
    Exactly the same here, quite a nuisance...
     
  12. studentx macrumors newbie

    Joined:
    Oct 1, 2011
    #12
    OSX is the source of the problem.

    Turn off all of the "Services" under "Sharing" in the OS X Control Panel to resolve the issue until Apple issues an update.

    ... then restart all of your Apple devices.
     
  13. studentx, Oct 30, 2014
    Last edited: Oct 30, 2014

    studentx macrumors newbie

    Joined:
    Oct 1, 2011
    #13
    I later used ONYX 2.9 which discovered that the sharing plist was damaged.

    "/Library/Preferences/com.apple.preferences.sharing.plist"

    I deleted the plist and enabled all of the "Services" under "Sharing" in the OS X Control Panel.

    So far that seems to have fixed the problem. Still testing.

    Note: I did not need to use any of the other solutions in this thread.
     
  14. arekarlsen macrumors newbie

    Joined:
    Oct 31, 2014
    #14
    Same to me. I used Onyx - no difference. Then I took restart on all AirPort stuff (Express, Time Capsule, AppleTv), then the problem disappeared.

    Maybe it after all was a combination of Onyx and a restart of the peripherals. I would have tried the latter first.
     
  15. rmcnelly macrumors regular

    Joined:
    Jul 23, 2011
    Location:
    Portsmouth, VA
    #15
    Well, the problem has returned even after trying Onyx. Maybe another restart of the Time Capsule...
     
  16. Frits48 macrumors newbie

    Joined:
    Aug 10, 2014
    #16
    Unplugging power and restarting my Time Capsule fixes it all the time for me.
    Then, over time, the multiple ID's show up again...

    Ridiculously annoying - I trust this will be one of the (many) things fixed in a future Yosemite update.
     
  17. rizal72, Nov 2, 2014
    Last edited: Nov 2, 2014

    rizal72 macrumors newbie

    Joined:
    Nov 2, 2014
    #17
    Here how I solved the issue, for everyone that could be interested:

    Noticed this log in Console right before Computer name changing:

    02/11/14 13:30:37,000 kernel[0]: en1 duplicate IP address 10.0.1.2 sent from address <Time Capsule Mac address>
    02/11/14 13:30:37,035 configd[25]: DHCP en1: defending IP 10.0.1.2 against BonjourSleepProxy <Time Capsule Mac address> 1 (of 5)

    What I did, following advices in this thread:

    1) deactivated all sharing options and Back to My Mac.
    2) I nuked the /Library/Preferences/SystemConfiguration folder.
    3) I deleted the /Library/Preferences/com.apple.preferences.sharing.plist file
    4) Restarted Time Capsule and Mac.
    5) reactivated sharing options and Back to My Mac again.

    Now everything seems to work and Mac name is not changing anymore (it seems...)

    ****edit*******

    After some hours:
    Name changed again. Shame. :(

    Now I'm trying to deactivate Nat mapping protocol...
     
  18. Mr. Buzzcut macrumors 65816

    Mr. Buzzcut

    Joined:
    Jul 25, 2011
    Location:
    Ohio
    #18
    Seems like the PC is not registering properly when it wakes and the sleep proxy holds on to the IP. It should release it once the PC is awake.

    Turning off sharing disables sleep proxy so the Airport is no longer answering for the PC when it is asleep.
     
  19. rizal72 macrumors newbie

    Joined:
    Nov 2, 2014
    #19
    Until next Yosemite update, I found a temporary solution here:
    http://ispire.me/fix-yosemite-rtc-alarm-wakeup-issue/

    You can disable the "change name" feature from discoveryd service with this command:

    sudo /usr/libexec/PlistBuddy -c "Add :programArguments: string --no-namechange" /System/Library/LaunchDaemons/com.apple.discoveryd.plist
     
  20. BobD2 macrumors member

    Joined:
    Aug 9, 2008
    Location:
    Massachusetts
    #20
    I've been seeing this issue as well. My computer (mid 2010 MacPro) is now named "computer" (4) (where "computer" is the name I gave it). I've seen this behavior for a while -- I am on OS X 10.8.5 with this computer. I don't remember if I saw this with 10.6.x (skipped 10.7 and 10.9 on this computer).

    My MacBook Pro (2011) is now on 10.10.0 and is now "computer" (3). I think I also saw this behavior with 10.9 (but not completely sure about that). I've been mostly ignoring it as it doesn't seem to be causing me problems with my current usage patterns.
     
  21. Pagemakers macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #21
    My MacBook air does this. None of my other macs do (they are connected by Ethernet if that makes a difference). 8.1.1 does not fix.
     

Share This Page