Finder Shows Incorrect Free Hard Drive Space

Discussion in 'Mac OS X Lion (10.7)' started by djshack, Nov 28, 2011.

  1. klauserator macrumors newbie

    Joined:
    Apr 17, 2015
    #26
    I had a similar issue in Yosemite. The Finder was showing 150 TB (yes, terabytes!) of free space. About This Mac had a sane (and presumably correct) value for free space. Disk Utility repair and Disk Warrior directory rebuild didn't help, but turning off time machine and restarting fixed it. Things still look OK after re-enabling time machine, but this definitely looks like a bug to me.

    ----------

    Also just found these two threads with more background:
    http://forums.macrumors.com/showthread.php?t=1421824
    https://discussions.apple.com/thread/3983143
     
  2. photographypro macrumors regular

    photographypro

    Joined:
    Jul 7, 2010
    Location:
    American in Pisa (Italy)
    #27
    Solution!!

    I had this issue after running the top 4 utilities of CleanMyMac3. My 750GB hard drive showed 703TB free!! At first I thought this program erased over 90% of my hard drive! But then I realized my drive isn't even 1TB, so obviously something was wrong. I ran disk first aid from the repair disk and everything showed ok, and I even repaired disk permissions, but rebooting back showed the same error.

    Here's the fix: Turn OFF Time Machine. Reboot your Mac. Turn Time Machine Back ON.

    For me that fixed the problem.
     
  3. klauserator macrumors newbie

    Joined:
    Apr 17, 2015
    #28
    ...and it's back

    Once again, I'm seeing 700TB free on my internal drive. Turning time machine off, rebooting, and turning time machine on again had fixed it, but it didn't last.
     
  4. Yellowbean12 macrumors regular

    Yellowbean12

    Joined:
    Feb 4, 2008
    #29
    Just coming in here to add that I had this problem a few minutes ago with Yosemite 10.10.3 showing my MacBook to have 4.93TB of free space(!), and that I successfully followed previous advice in this thread to fix it.

    1. Switched off Time Machine in system preferences.
    2. Rebooted.
    3. Turned Time Machine back on again.

    Problem solved.
     
  5. klauserator macrumors newbie

    Joined:
    Apr 17, 2015
    #30
    OK, this is getting ridiculous. I just had the finder tell me that I had over 2 PB of free space. Yes, two petabytes! The time machine off/on routine has fixed it for now, but I'm sure it'll be back.
     

Share This Page