Finder Sidebar "Desktop" Keeps Reappearing?

Discussion in 'macOS Sierra (10.12)' started by John25, Nov 18, 2016.

  1. John25 macrumors newbie

    Nov 11, 2010
    Has anyone else noticed the "desktop" sidebar favourite keeps reappearing even if hidden? I'll uncheck the box but it keeps popping up in the sidebar after a few hours. Not sure if this is a known bug or not?
  2. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    I imagine most people have it checked on purpose. Perhaps that's why I'm the first to respond...?
  3. dianeoforegon macrumors 6502a


    Apr 26, 2011
    I have the opposite problem. My Desktop keeps removing itself. I'm guessing this is similar to other issues like every restart, my sound is muted and my Logitech Mouse does not remember any of it's custom settings. All real pains to reset each time.
  4. airlied macrumors 6502


    Jul 8, 2011
    This is because you enabled icloud drive desktop and document folder syncs on system preferences and trigged the bug.

    if you really dont want to see desktop icon on your sidebar, turnoff the function under icloud panel. or wait for apple to fix it (if they care).
  5. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Aug 5, 2001
    Hah, I thought it was just me! But yes, I've had this occurring on several machines the last couple of weeks. Interesting thing is that they run a mix of 10.11 and 10.12.

    I haven't noticed it prior to a few weeks ago, and thought I had just forgotten to remove it, but was wondering why I would have forgotten it on more than one machine (Command-D is faster when the desktop is needed). But since I am apparently not the only one, it can only be a bug.
  6. John25 thread starter macrumors newbie

    Nov 11, 2010
    Has anyone found a fix for this yet? The "desktop" label in the sidebar of Finder keeps re-appearing no matter how many times it is "removed" from the sidebar.
  7. AngerDanger macrumors 68040


    Dec 9, 2008
    Try navigating to ~/Library/Preferences and deleting then alt + rightclick on Finder's Dock icon and select Relaunch from the menu that appears. Then hide Desktop again and see if it reappears.

Share This Page