Finder thinks my Bootcamp partition is a "CD, DVD, or iPod".

Discussion in 'macOS' started by acosmichippo, Jul 8, 2008.

  1. acosmichippo macrumors regular

    Joined:
    May 7, 2008
    #1
    hi there... i've been perusing this site for a while, but have only recently been perturbed enough by this little problem to post a question about it. I did try searching and found one other person with the same issue, but there were no replies.

    Anyway, here are the details: I prefer only having physically removable storage devices show up on my desktop, so I set finder to show "CDs, DVDs, and iPods" and "External Disks" on the desktop. The problem is, when I do this, the following happens:

    [​IMG]

    The "Untitled" item you see there is my NTFS bootcamp partition of my MacBook Pro's internal Hard Disk. Apparently Finder thinks it's a CD, DVD, or iPod... Is there anyway to reclassify it as a "Hard Disk" so it's not on my desktop all the time? I've combed through Finder preferences and the "get info" items, but haven't turned up anything... is there maybe something I can do in terminal?

    Thanks so much for any help.
     
  2. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    Boot to Windows, open My Computer, right click on Drive C:\ and select properties. Label your Windows partition something like "Windows XP HD" or "Vista HD". Press OK.

    Boot back to OS X and reset the parameters for Finder. See if that works.

    Regards.
     
  3. acosmichippo thread starter macrumors regular

    Joined:
    May 7, 2008
    #3
    thanks for the suggestion. I successfully renamed the drive (which is also something i was wondering about), and reset finder settings, but Finder still thinks it's a CD, DVD, or iPod.
     
  4. ookamiwarrior macrumors newbie

    Joined:
    Feb 2, 2009
    #4
    I have done the same and I am having the exact same issue.

    In the "Get Info" window the Windows partition actually shows it's kind as a "Volume", the same as any other partition on my drive. This makes me believe that the problem stems from the fact that it is an NTFS formatted partition.

    Leopard doesn't really understand NTFS properly. It does however understand FAT as it can natively format a drive in that way. Because it doesn't understand it, it classifies it as "CDs, DVDs, and iPods" for lack of a better idea. It still seems stupid to me though, because it does recognize that it is NTFS and that it is a volume.

    One option would be to reformat and reinstall your Windows partition, and use the older FAT formatting. That just might do it.
    I can't do this because I am running the Windows 7 Ultimate BETA, and it can only be installed on NTFS.
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #5
    Reformatting for 1 disk icon is overkill. Submit the bug to:

    apple.com/feedback

    or bug report.
     
  6. acosmichippo thread starter macrumors regular

    Joined:
    May 7, 2008
    #6
    Well, I ended up finding a workaround. If you boot into windows, and rename the C:\ drive as ".whatever" (yes, the period is necessary), OSX will not display the icon on the desktop, but it will still be viewable in finder just fine. I find this acceptable, but there should be a better way.
     
  7. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
  8. Trip.Tucker Guest

    Joined:
    Mar 13, 2008
    #8
    Do you just want to hide it? If so, correct the volume name in Windows (.names are not a good fix), then run this in a Terminal shell:

    sudo SetFile -a V /Volumes/Windows

    where Windows is the name of the volume. If you don't recall, just run:

    ls /Volumes

    to identify the name.

    You'll need to restart Finder for this to take effect. You can wait until you next reboot or press Command+Shift+Escape, then highlight Finder and kill it.... or from within your Terminal shell: killall -KILL Finder

    Finder will automatically restart.
     
  9. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #9
    Try these preferences
     

    Attached Files:

  10. acosmichippo thread starter macrumors regular

    Joined:
    May 7, 2008
    #10
    Thanks, that is more along the lines of what I was hoping to try. I can't do it right now as my mac is in service, but I will when I get it back.

    By the way, don't you guys think one "report it to apple" response is sufficient?
     
  11. acosmichippo thread starter macrumors regular

    Joined:
    May 7, 2008
    #11
    That would remove the disk from the desktop, but it would also remove all optical discs and external disks, which I would prefer to see on the desktop.
     

Share This Page