Finder unexpectedly quit while trying to restore its windows...

Discussion in 'Mac OS X Lion (10.7)' started by JdeM, Sep 11, 2011.

  1. JdeM macrumors newbie

    Sep 11, 2011
    Hi. My Finder keeps coming up with the message "The application "Finder" unexpectedly quit while trying to restore its windows" and it gives me the option to restore the windows. Whether I chose to restore or not, nothing happens. The screen keeps flashing - my desktop icons flash on and off every three seconds. Can't rebuilt the Finder (it won't do anything at all). Clicking icons doesn't do anything. If I put a CD in (wanted to use Disk Warrior) it will appear on the desktop but nothing happens if I click it. If I click my hard drive I can't get into it. I can access stuff through the Launchpad, however. I initially wanted to reinstall the OS but I can't start up from my Snow Leopard installation disk. (I am using Lion and have tried reinstalling that, but it didn't solve the problem). So basically, I can't do anything!

    I read a thread somewhere on this forum where someone said that this could be solved by going into the Terminal and getting into the Library/Saved Application State and looking for a file called Apparently, deleting this solves the problem.

    I've been trying to sort this problem out for 24 hours now and I'm a bit tired so forgive me if I'm being thick. I am in the "Saved Application State' directory in Terminal - I have found about 30 things in there including the Finder.savedState one - and I'm trying to delete this Finder file. I read that I must type in

    rm -rf /Users/Username/Library/Saved Application State/

    I've tried this various times but the file is still there.

    Do I have to be in the Saved Application State directory to type this, or do I just open the terminal and type it there? I have tried both, without success. My username is jane but in the terminal this is what appears on the first line:

    janes-imac:~ jane$

    If someone could please give me the exact command to type, and from where exactly, I'd be very grateful as it is a very sad anniversary for me today (as it is for many people) and this is just making me feel really defeated.

    Thank you very much for any help you can give me.

  2. danielhanlon macrumors newbie

    Jan 18, 2002
    Finder problem

    Hi Jane,

    You need to replace where in says "Username" in the command you typed, with your username i.e. jane

    So that'd be opening a new Terminal window and typing:

    rm -r /Users/jane/Library/Saved Application State/

    (the f in -fr shouldn't be needed).

    I've had exactly the same problem and getting rid of savedState stops the pop-up message but the Finder is repeatedly crashing and restarting..... I have to say that whilst there are some nice new features in Lion it is definitely very buggy.....

  3. Quad5Ny macrumors 6502a


    Sep 13, 2009
    New York, USA
    1. Open Terminal
    2. Type: cd ~/Library/Saved\ Application\ State/
    3. Type: rm -R
    4. Type: killall Finder
    5. Quit Terminal
    6. Logout then back on

    (Using ~ will automatically substitute in your home folder.)
  4. stepahbers macrumors newbie

    Nov 26, 2011
    restore windows the application "Finder" unexpectedly quit while trying to restore it


    I have the same problems and honestly I do not know what and how to do to solve this problem. I have tried to follow the way Jane was writing here but now the finder would not start at all. it was flickering with the message but now nothing happens and would not even relaunch.

    21.5-inch, Mid 2011
    Processor 2.5 GHz Intel Core i5
    Software Mac OS X Lion 10.7.2 (11C74)

    i would appreciate if anyone could help and tell me what to do and how. thank you.
  5. jhfunds macrumors newbie

    Dec 14, 2011
    I have the exact same problem, can't get that restore window to go away, and I can't access to my finder at all.
    Jane and Stephan, did you ever solve the problem? I tried all the suggestions on your post, but I kept getting "No such file or directory", I need help desperately too. I would greatly appreciated if anyone could help me.
    Thank you.

  6. unobtainium macrumors 68020

    Mar 27, 2011
    I'm getting a similar message, but it has to do with iTunes. I'm guessing these are both glitches with Saved States in Lion?

    Mine says: "iTunes quit unexpectedly while trying to restore its windows"

    It's impossible for me to start iTunes now and I'm not sure what to do.
  7. MikeSyd macrumors newbie

    Jan 31, 2012
    I have this problem (finder unexpectedly quit while trying to restore its windows)...

    Has any solution been found for Jane's question?
  8. SoniXAnT macrumors newbie

    Feb 11, 2012
    Hi, I created another account on the same machine and this solved everything.
    Hope this helps.

  9. heydesign macrumors newbie

    Jun 20, 2012
    Solution for flashing finder

    While adding another account works to stop the finder flashing, it was not an option as I didn't want to have to reset and reload everything from my main 'flashing' account. After much reading and many suggestions that did not work the following finally did.

    NOTE: This flashing started when I downloaded the latest software update 10.7.4.
    I think Apple has dropped the ball. Lion has been atrociously glitchy.

    1. Chances are that you can't use finder to drag anything into folders. If this is the case go to Apple/System Preferences/Users & Groups and create another temporary account with administrative access. Log out of the 'flashing' account and into the temp account.

    2. In safari to and download the Maintenance software for your version of Lion.

    3. Open it, drag the 'maintenance' file to your applications/utilities folder. Double click to open the program and run the default tests.

    4. On completion restart the computer and log back in to the 'flashing' account, which by now should be fixed.

    This did it for me. Its a pain so I hope this info helps other people who may be affected.
  10. Jearoon macrumors newbie

    Aug 18, 2011
    Thanks for this buddy, i had the same problem and this fixed it!
  11. Sueco macrumors newbie

    Oct 2, 2012
    Problem still there

    For me it started with update 10.7.5 and Finder keeps crashing. I ran the maintenance tool and the first time looked like it worked but it crashed again.

    Incredible Apple is doing this.

    I will go on searching a solution
  12. ddr4h macrumors newbie

    Mar 15, 2013
    Thank you!

    I didn't even have an account on here, but i made one just to thank you for saving my laptop. I took it to the Genius Bar and not even they could help me, they were ready to reboot my entire system, and they suggested I buy the firewire cord to transfer my files into another mac computer before they do so, which costs $40. I bought the wrong one by another employee's suggestion and it really ruined my day because I'm a graphic design student, it's finals week, and i really needed to access my files and programs for my final projects. But anyway, thank you so much for taking the time to post this! It truly helped me a bunch, and I'm sure it's helped many others too ^^
  13. calumwoltering macrumors newbie

    Jun 14, 2013

    Hey my name is calum woltering and i just got a macbook update version 10.8.2 and i was on a program and fell asleep on it, i woke up to flashing Finder unexpectedly quit while trying to restore its windows and something else i cant quite remember.
    now it has made me non able to open finder or see any desktop icons and click on them its like i lost all my dock icons. every 1 hour or so the desktop icons pop up but when i go to click on them i get the rainbow wheel and they go back away and the flashing Finder unexpectedly quit while trying to restore its windows... comes back up and i see responces saying to type certain things into terminal and kill finder then logout and in but it wont let me logout because finder wont quit and i dont know how to solve this. please help!
  14. volcomjerk macrumors newbie

    Sep 17, 2005
    The default settings in Titanium didn't work for me.

    See attachment for my settings.

    Attached Files:

Share This Page